Stuck on reached target graphical interface

Hello i have updated my system yesterday and since then i’m not able to use use the non LTS version. When i try to boot the system using it i’m stuck on reached target graphical interface and the screen flickers and i’m unable to even use shift + f2. Here’s my HW info and journal I have tried updating my system in chroot but everything is up to date. I also used nvidia-all to downgrade my gpu drivers since there were problems with a game i play and older drivers fixed that.

Seems like another NVIDIA driver issue.

Are you able to use the LTS kernel?

Yes i’m currently using LTS kernel

I’m going to tag an expert @manuel because I think it’s your NVIDIA drivers causing the issue.


It look like you have an older version of the nvidia drivers? Is your system updated? Also i don’t see any amdgpu? Do you have it set for dedicated graphics only? I also see you are using Wayland?

Drivers should be 525.89.02
I would update your mirrors and try updating again.

Device-1: NVIDIA GA104 [GeForce RTX 3060 Ti] vendor: Micro-Star MSI
    driver: nvidia v: 525.60.11 arch: Ampere pcie: speed: 5 GT/s lanes: 16
    ports: active: none off: HDMI-A-1 empty: DP-1,DP-2,DP-3 bus-ID: 07:00.0
    chip-ID: 10de:2486

Can you post

inxi -Ga

Edit: There is also another Bios update F64a that has the latest AMD AGESA

Edit2: Just realized Ryzen 2600X doesn’t have onboard graphics. :man_facepalming:

1 Like

Can you post the output of command

pacman -Qs nvidia

As @ricklinux pointed out, you have an older version of the Nvidia driver. Any reason?

And the BIOS update might help, worth checking. But if you do the BIOS update, make sure the new BIOS is exactly for your machine type.

I have fixed it. What fixed it was pacman -Rd nvidia-utils-tkg and nvidia-dkms-tkg and installing normal utils and nvidia-dkms


the reason was league of legends was broken on an update version broke it so i reverted using nvidia-all to downgrade but i have swaped back and it works now

As i said i think there is also another UEFI Firmware(Bios) update F64a which has the new AMD AGESA

I’ll make sure to install it too

As a tip, using other than official nvidia drivers (from the Arch repos) may cause strange results. So if you have unofficial (essential) packages installed, it is good to mention that right from the start. In troubleshooting all details are important.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.