Stuck on loading stage due to Mediatek mt7922

Hi, I am trying to install endeavour os on ROG G14 2022, but the iso stuck in the stage says:

[10.332425] mt7921e 0000:05:00.0: Timeout for driver own

and it just does nothing, I cant even get into the install system, how should I fix this?

Are you using a usb dongle for WiFi or is it a built in chip?

built in chip, I try to replace, but I stripped the screw…

I don’t see information on the mt7922. I assume it is the AX WiFi standard. The 7921 uses the mt76 module so since it lists 7921e i think maybe is still same. :thinking:

Do you have Wifi on the live ISO?

Edit: Also are you using WiFi to install?

I cant even operate anything actually, it is like this
https://ibb.co/6JvZjgj

So it won’t even boot on the live ISO is what you are saying?

yes, it booting into it, but loading forever

Maybe try to blacklist the module on boot by adding this to grub command line. Press e when the grub menu loads and add this to the line. Not sure if this will work but worth trying. Then press enter to continue booting.

initcall_blacklist=mt76

Edit: If it allows the live ISO to boot up then you may have to load the module to get WiFI unless you can use ethernet.

thanks, I will try that, but how can I load the model back? what command should I use? and is there a model or driver for mt7922? since I notice here https://wiki.archlinux.org/title/ASUS_ROG_Zephyrus_G14_(2022)_GA402 it says the wireless have some issues for the previous driver

Edit:
I just tried the arch iso (vanilla one), it boot into iso without any issues, and connect to wifi also well…

The problem is solved by change an iso… seems that the previous iso might be beoken somehow…

That’s good news since i couldn’t see any reason why the mt76 module wouldn’t be loading. You are not the first user with a mediatek chip.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.