Stuck on Loading initial ramdisk

Hi all,

I’ve been using EOS for about a year now and recently my laptop stopped booting and I’m stumped.

Before the issue began, I ran yay and had a rather large update. Now both the normal boot option and the backup image get stuck at Loading initial ramdisk. I am not able to switch to another TTY and it does not make a new dmesg entry. My latest dmesg entry was when the laptop was still working in May :slight_smile:

I have used the live USB to chroot into the existing install and create a new image with mkinitcpio or yay (as part of an update) and have not had any luck. I have done updates via yay and pacman -Syu as well. I suspect I might be mounting the partitions wrong or something else basic.

I’ve been mounting /dev/nvme0n1p2 to /mnt/ and /dev/nvme0n1p1 to /dev/boot. Then I arch-chroot /mnt.

Hardware:

System:
  Kernel: 5.15.8-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
    Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 wm: xfwm dm: LightDM
    Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Laptop System: Dell product: XPS 13 9310 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0DMPXV v: A00 serial: <superuser required> UEFI: Dell
    v: 3.1.0 date: 07/22/2021
Battery:
  ID-1: BAT0 charge: 43.5 Wh (86.3%) condition: 50.4/51.0 Wh (98.8%)
    volts: 7.6 min: 7.6 model: LGC-LGC6.5 DELL 2XXFW15 serial: <filter>
    status: Discharging
CPU:
  Info: quad core model: 11th Gen Intel Core i7-1185G7 bits: 64 type: MT MCP
    arch: Tiger Lake rev: 1 cache: L1: 320 KiB L2: 5 MiB L3: 12 MiB
  Speed (MHz): avg: 1690 high: 4584 min/max: 400/4800 cores: 1: 4584 2: 629
    3: 460 4: 471 5: 4576 6: 521 7: 649 8: 1635 bogomips: 47936
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Dell
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9a49
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-6:3 chip-ID: 0c45:6a0f
  Display: server: X.Org 1.21.1.2 compositor: xfwm4 driver: loaded: intel
    unloaded: modesetting alternate: fbdev,vesa resolution: 3456x2160~60Hz
    s-dpi: 96
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.3.1
    direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Dell
    driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3 chip-ID: 8086:a0c8
  Sound Server-1: ALSA v: k5.15.8-arch1-1 running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
  Device-1: Qualcomm QCA6390 Wireless Network Adapter [AX500-DBS ]
    vendor: Rivet Networks driver: ath11k_pci v: kernel bus-ID: 72:00.0
    chip-ID: 17cb:1101
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB
    driver: r8152 bus-ID: 2-1.4:3 chip-ID: 0bda:8153
  IF: enp0s13f0u1u4 state: down mac: <filter>
Drives:
  Local Storage: total: 961.37 GiB used: 0 KiB (0.0%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: PM9A1 NVMe 1024GB
    size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 43.9 C
  ID-2: /dev/sda type: USB vendor: Generic model: Centon USB size: 7.5 GiB
    serial: <filter>
Partition:
  ID-1: / size: 10 GiB used: 27.9 MiB (0.3%) fs: overlay source: ERR-102
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 73.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0 fan-2: 0
Info:
  Processes: 245 Uptime: 2m Memory: 31.07 GiB used: 1.86 GiB (6.0%)
  Init: systemd v: 249 target: multi-user.target Compilers: gcc: 11.1.0
  Packages: pacman: 888 Shell: Bash v: 5.1.12 running-in: xfce4-terminal
  inxi: 3.3.10

fdisk -l output:

Disk /dev/nvme0n1: 953.87 GiB, 1024209543168 bytes, 2000409264 sectors
Disk model: PM9A1 NVMe Samsung 1024GB               
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 8A8EAB7F-3175-1A49-B1DF-3C5AFC0F0917

Device              Start        End    Sectors   Size Type
/dev/nvme0n1p1       4096    1052671    1048576   512M EFI System
/dev/nvme0n1p2    1052672 1928706842 1927654171 919.2G Linux filesystem
/dev/nvme0n1p3 1928706843 2000397734   71690892  34.2G Linux swap


Disk /dev/sda: 7.5 GiB, 8053063680 bytes, 15728640 sectors
Disk model: Centon USB      
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x6abbeac5

Device     Boot   Start     End Sectors  Size Id Type
/dev/sda1  *         64 3742559 3742496  1.8G  0 Empty
/dev/sda2       3742560 3951455  208896  102M ef EFI (FAT-12/16/32)


Disk /dev/loop0: 1.68 GiB, 1808896000 bytes, 3533000 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Any help is greatly appreciated!

If this is not a typo mistake, this is what is wrong. It should be /mnt/boot/efi AFAIK. If you check /dev/nvme0n1p1 contents, you would see kernel images, if it was originally mounted at /boot.
If you don’t see images, then it should be /mnt/boot/efi.

this point can stuck also with high temp and no fan

For two days now, I have the exact same problem. I have so far “solved” this by booting into an emergency boot USB stick (with Endeavour on it), afterwards it seems to boot normally. However, I can also boot into the fallback entry in grub, and that boots normally.

Can you try that? Does that work for you too?

Same problem here on my desktop. My laptop works just fine. I think it might be related to the grub issue, but I don’t know. If I plug in my thumb drive that has a portable install of Endeavour on it the system boots in both the USB system and the system installed on the desktop. However, when I unplug the drive it hangs up on “loading initial ramdisk…”.

I am not sure how to fix this. The laptop works just fine, but I just reinstalled Endeavour from scratch since it would not boot after an update and I did not want to fight fixing it with an encrypted btrfs setup.

I also tried installing zen and lts, both have the same problem booting and the fallback does not boot either without the usb drive.

I am not so sure anymore that it was a grub related issue. After a while I noticed that the UEFI screen was showing much longer than usual, so maybe there was some kind of hardware detection issue UEFI didn’t notify about.

I opened up my computer and cleaned it a bit, and since then I cannot reproduce the endless boot anymore.

I’m not to worried about it. I think I will end up doing a fresh install on my desktop anyway. I took the encryption of my laptop and did the default btrfs setup and it seems to work smoother. Maybe there was a glitch in the setup or something in the old Apollo images.

Either way I am extremely happy with Endeavour. I have always wanted to be on Arch but always ended up on a Debian base because my computer would be super buggy with Arch, but now it looks like that was Manjaro related. Endeavour has been even more stable than Debian has been for me. I guess it all has to do with what packages you install and the method of such.

Hi all, I abandoned that install on my laptop. I backed up my home directory and reinstalled fresh and it works fine. I still don’t know what happened, but I gave up :slight_smile: