Stuck on a black screen after running "nvidia-installer-dkms"

Hi, I’m on XFCE and I tried following the endeavouros guide on nvidia, but I’ve tried it like 3 times and it always get stuck on boot after I run the commands and i have to reinstall the os. Ima noob so id appreciate any help, as i did enjoy Endeavour and if i can’t solve this ill unfortunately have to switch OS

Im running it on a laptop intel i5 10300h, nvidia gtx 1650 so i assume it is optimus

I’m not sure why so many people have issues with Nvidia. I don’t have any Hybrid laptops to test so I only can test my GTX 1060 in a desktop which i have no issues with what so ever. When you say you tried 3 times? Is that 3 installs you mean?

Edit: Also are you able to get into tty screen and log in as root?

inxi -Ga

I haven’t tried that, as I didn’t know that was possible…And after it got stuck the first time, I reinstalled the OS as I didnt know what to do, thats what I did 3 times. I’m not sure if I can get into tty

Well it’s up to you what you want to try. You can either try another reinstall if you want. So just so you know. If you select the default entry in grub when it boots up it will install with the open source Nouveau driver. Just so you know as long as it is able to boot on it. The other option in grub is the non free or Nvidia drivers. When you select that entry it is supposed to install the Nvidia drivers.

So here are two options. Well actually there’s three but each take time so I’ll give you these two. You could try installing with the default option as long as it will boot up on it and then install Nvidia drivers after the install as it will install the open source nouveau driver.

Option two is use the non free entry in grub but before you do that you want to add the nvidia-dkms package to the user_pkglist.txt on the live installer. So what you do is in a terminal run sudo xed and then it will open the editor as root and you can open the user_pkglist.txt that is on the live ISO. Just add nvidia-dkms as a package and then save and start the installer. This will hopefully guarantee an install that works.

Edit: I would try option 2 first.
Edit2: Also when you start the Live ISO i would also update the mirrors first from the welcome app.

Sorry forgot to run the inxi -Ga heres the current output:
Graphics: Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Lenovo driver: i915 v: kernel
bus-ID: 00:02.0 chip-ID: 8086:9bc4 class-ID: 0300
Device-2: NVIDIA TU117M vendor: Lenovo driver: nvidia v: 470.63.01
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f99 class-ID: 0300
Device-3: Syntek Integrated Camera type: USB driver: uvcvideo bus-ID: 1-6:3
chip-ID: 174f:244c class-ID: 0e02 serial: 0001
Display: x11 server: 1.20.13 compositor: xfwm4 v: 4.16.1 driver:
loaded: intel,nvidia unloaded: fbdev,modesetting,vesa alternate: nouveau,nv
resolution: <missing: xdpyinfo>
Message: Unable to show advanced data. Required tool glxinfo missing.

Also I did install the non-free nvidia drivers option, so idk but tyvm for the help

So if you can boot into a tty then there is option 3.

Edit: Option 3 would be to add some entries to the default grub and update it. Then add nvidia to the modules section of the mkincpio.conf

Then i would regenerate the kernel modules.

So it’s your choice. Tell me what you want to do or try.

The driver is installed it probably just didn’t configure properly. This is an issue with Nvidia a lot of the time. Especially with Hybrid graphics.

Suggestion: You would not want to burn up a notebook with gaming, so I would
try just nouveau free driver, it is also less complicated for the updates to come.

1 Like