Stuck on 8%

I restarted the iso and updated mirrors and tried it again and its still stuck its been 30mins
My connection is like 800kbps
Its doing stuff in the terminal
QML Component default slideshow next slide
Secure boot and fast boot are disabled
it is running on Usb 2.0

Welcome aboard! Your connection is very slow. 8% is the point at which the keys are refreshing. It could take a long time.

Ah okay ty

Its been 2 hours since i started the install its still doing the same thing

First welcome to the purple side of Linux. Second as @Elloquin said your connection is around 0.8 Mbps. Which is not going to cut it for a net install.

Stuck on 8% means that keys are getting refreshed and I think the mirrors also get updated at this point. And it will take a long time to finish the install because there much other stuff that needs to be downloaded. Which includes your selected desktop environment, base OS stuff, and any other selected tools.

So at the mentioned speed, it’ll take a very long time or you could try the offline default installation which doesn’t need to get anything from the internet. So it would be faster (edit).

1 Like

My internet is 7 megabits per second
So 800 kilobytes a second
Not 0.8 mega bits
How much stuff does it download?
Like how much gb
Btw i want kde so im using online install

The s

That happens after this step, if I remember correctly. Also you can see where exactly the installer currently is in the debug window. So I guess he’s still stuck inside the key refresh part of the installation.

From my experience with a 1.4 MB/s connection, it shouldn’t take this long. It definitely is weird.

@Adi, does the debug window output something new, besides the QML slideshow stuff?

Well, I presumed it was .8Mbps and I think @Elloquin also did the same. I can’t comment on how much it downloads because it differentiates according to the selected DE and other stuff. I think there was another thread and many suggested it might be due mirrors.

Its just the Qml slideshow yes

For me it took over 2 hours for online installation of kde and my network speed was over 600kB/s - 1.1MB/s

Yep its broken for me it doesnt even connect to archlinux.org guess ill have to use something else rip
Tried for 6 hours and no success

Please try again when the new ISO is released as it is a whole new process with mirror ranking and changed installation processes.

Try changing the mirror with reflector before online installation.

post the output of inxi -Faz you can do it from the live iso. If inxi is not installed install it. This could have something to do with r8168.

I agree it would be nice to see what the hardware is.

I did a test with a VM. It took me around 25 - 26 minutes to complete the entire installation. The selected packages are eos base and KDE.

This is my download speed (https://librespeed.org). You can use this link to see the results.

I did a mirror update.

Saved the list.

After that below is the start time of the installation.
vmStartInstallStartTime

This is the end time.
vmStartInstallStopTime2

So my conclusion is mostly the slow installs might be due to slow internet connections.

2 Likes