Stuck in TTY


After recovering from a sickness, I want to tackle this issue without just re-installing the system.
The very last thing I remember from before I am unable to launch X, was installing prime-manager for the laptop.
Why would that break things? I do not know. But after uninstalling it nothing changed, so maybe that is not it at all.
Trying different display managers (login screens plus whatever else they do) does not help.
I’ll provide outputs soon, but how does one go about trouble shooting this?

Start with giving the info on your hardware. If you can get into a TTY and have internet access provide the link.

inxi -Faz | eos-sendlog

inxi -Faz output

i should mention that it does not matter if the GPU has drivers or not.
If I am on stable, the gpu has no drivers. If I am on latest, the gpu does have drivers.
Regardless of either, the GUI does not load and I still get the error when running startx.
even when I disable the gpu in BIOS, and only have it use the intel igpu, it does not load up.

the error when doing startx or startxfce4 is
“startx cannot run in framebuffer mode. please specify busIDs”


Have you tried adding the following kernel parameter in the default grub command line and then update grub.


I checked to make sure it was there. Was by default im pretty sure. But yes.

Post the link.

cat /etc/default/grub | eos-sendlog

strange. i feel like I have seen that option before in some nvidia setting file. the one that nvidia-inst makes, perhaps. but as I say, this happens regardless of GPU


Have you added this yourself in the file, or added by some utility? It was supposed to be inside Cmdline values at the top, for kernel parameter. :face_with_head_bandage:

With only little info, I can only ask my :crystal_ball: , which says, there are files in the system that block X from starting. Mystery…

Would you mind posting this:

for Xconf in $(ls /etc/X11/xorg.conf.d/*.conf | grep -v keyboard); do echo -e "\n $Xconf" ; cat "$Xconf" ; done
for Xconf in $(ls /etc/modules-load.d/*.conf); do echo -e "\n $Xconf" ; cat "$Xconf" ; done
for Xconf in $(ls /etc/modprobe.d/*.conf); do echo -e "\n $Xconf" ; cat "$Xconf" ; done
journalctl -b -p3 --no-pager --no-hostname
for Xlog in $(ls /var/log/Xorg.?.log); do echo -e "\n $Xlog" ; grep -E "(EE)|(WW)|failed|Time" "$Xlog" ; done

It’s not there? Not sure where you are looking but it needs to be added here.

sudo nano /etc/default/grub

add to your command line ibt=off

This is the line where you add it.

GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=92841282-6cc4-48ed-8453-f44afa6fcc52 loglevel=3 nowatchdog nvme_load=YES nvidia-drm.modeset=1" 

Then you need to save the file with

ctrl + o then enter to save
ctrl + x to exit nano

Then you need to update grub.

sudo grub-mkconfig -o /boot/grub/grub.cfg

If you are working from a TTY and logged in as root you don’t need to use sudo.

updated to fix that, updated grub, then rebooted, still in TTY when it finished booting.
my current grub file:

Okay what does this show

inxi -Ga

Edit: You can do it this way if it’s easier and post the link

inxi -Ga | eos-sendlog

Also what desktop do you have installed? What display manager are you using? And what do you have installed? optimus-manager or nvidia-prime?

Edit: Also what is your hardware. Post the link

inxi -Faz | eos-sendlog

ouch, my fingers.
First script

Second script [no file error]

Third script

the journal [!!!]

and the last script. [no file error (yes, i did try correct the typo too)]

xfce. lightdm, and changing does not fix the issue. i have installed very little, steam and maybe awesomewm among other programs. still wouldnt want to reset you understand.
im not sure about optimus-manager or nvidia-prime, i was going to tackle that side of things with a GUI/games/heavy battery stuff to work with, given that’s what the gpu is for in my use-case.

inxi -Faz is shown above, but here is a new link.

Jul 31 22:40:25 systemd[1]: Failed to start Light Display Manager.

What does this show?

systemctl status lightdm

It also doesn’t show any nvidia drivers loaded. Did you install nividia drivers?

Device-2: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] vendor: Lenovo driver: N/A
    alternate: nouveau, nvidia_drm, nvidia non-free: 515.xx+ status: current (as of 2022-06)
    arch: Ampere process: TSMC n7 (7nm) built: 2020-22 bus-ID: 0000:01:00.0 chip-ID: 10de:25a0
    class-ID: 0300

i sure have. as I mentioned, the drives do show up depending on my kernel version.
no matter what, i 100% have the drivers installed, one way or another

Post the other command

systemctl status lightdm

systemctl status lightdm

Did you try

sudo systemctl enable lightdm
sudo systemctl start lightdm