Stuck after system update

At first after system update and rebooting i was stuck at this place


Then some people said to install the nvidia drivers and optimus manager and after that and reboot stuck at this

I am a total newbie and i am stuck at this
My laptop is a legion 5 with i7 11gen and rtx 3060

Some quick questions and ideas…
What file system did you use?
Can you get to a tty (ctrl+alt+F3)? If you can:
Re-run update
Check the logs

If you cannot get to a tty, chroot of live media and try from there.

Legion 5 but AMD/rtx3070 here.

Used ext 4 file system , i can go to tty i also re-ran the update but still the same

Reboot, spam F2, swap to switchable graphics, something is wrong, I can’t reboot using nVidia.

I run Sway so have been using the switchable graphics (in my case AMD) as nVidia is shit on wayland. I cannot boot to nVidia.

@jonathon are you seeing this?

:edit:
Tried downgrading linux-zen
Tried LTS kernel
Tried downgrading nVidia to 515-40-03
Tried rebuilding mkinitcpio for all kernels and rebuilt grub (for completeness)

Nothing worked am on iGPU posting this.

:edit2:
Was in the process of setting up snapper, the image from 14th boots, so it is something that has update after 8pm UK time.

──────┬─────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
       │ File: /home/xircon/.updates/2022-06-15T08:23
───────┼─────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
   1   │ fastfetch-git r780.a04daf1-1 -> r783.3d8a071-1
   2   │ libutempter 1.2.1-2 -> 1.2.1-3
   3   │ vulkan-icd-loader 1.3.213-1 -> 1.3.217-1
   4   │ welcome 3.29-1 -> 3.30-1
   5   │ wezterm-git 20220612.201748.75066cb5-1 -> 20220614.094817.62744bf0-1
───────┴─────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
───────┬─────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
       │ File: /home/xircon/.updates/2022-06-15T20:52
───────┼─────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────
   1   │ fastfetch-git r783.3d8a071-1 -> r784.ae8b5bd-1
   2   │ inxi 3.3.17.1-1 -> 3.3.18.1-1
   3   │ lib32-vulkan-icd-loader 1.3.213-1 -> 1.3.217-1
   4   │ nushell 0.63.1-1 -> 0.64.0-1
   5   │ opencl-headers 2:2022.01.04-1 -> 2:2022.05.18-1
   6   │ vivaldi-snapshot 5.4.2704.3-1 -> 5.4.2706.3-1
   7   │ vulkan-extra-layers 1.3.204.1-1 -> 1.3.216.0-1
   8   │ vulkan-extra-tools 1.3.204.1-1 -> 1.3.216.0-1
   9   │ vulkan-tools 1.3.213-1 -> 1.3.217-1
  10   │ vulkan-validation-layers 1.3.211.0-1 -> 1.3.216.0-1
  11   │ xkeyboard-config 2.36-1 -> 2.36-2
───────┴─────────────────────────────────────────────────────

Vulkan looks a bit suss :smiley:

Got it down to these culprits:

#!/usr/bin/env bash
sudo pacman -S solid --noconfirm  <<<< Not this one :D
sudo pacman -S srt --noconfirm
sudo pacman -S threadweaver --noconfirm

It is one of them…

Not sure if this is related to nvidia drivers. Try this kernel parameter in the default grub command line and update grub.

ibt=off

Isn’t that intel only?

I thought it was for an Nvidia issue?