Strange message about updating electron24

Recently I’m getting this message after running yay -Syu --aur

:: Searching AUR for updates...
 -> Orphan (unmaintained) AUR Packages: electron24
:: 7 dependencies will also be installed for this operation.
   extra/gn                 -> 0.2130.7367b0df-1
   (make dependency of electron24)
   extra/gperf              -> 3.1-5
   (make dependency of electron24)
   extra/lld                -> 16.0.6-1
   (make dependency of electron24)
   extra/llvm               -> 16.0.6-1
   (make dependency of electron24)
   extra/python-httplib2    -> 0.22.0-4
   (make dependency of electron24)
   extra/python-pyparsing   -> 3.1.1-1
   (make dependency of electron24)
   extra/yarn               -> 1.22.21-1
   (make dependency of electron24)

:: 1 package to upgrade/install.
1  aur/electron24  24.8.8-2 -> 24.8.8-3
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
 -> Excluding packages may cause partial upgrades and break systems

What I find strange is that this update apparently involves updating other packages not installed from AUR but from official sources, so I don’t know if I should update it, ignore it or delete it somehow.

You probably don’t need electron24 any more. If you can remove it with sudo pacman -R electron24, that is all you need to do. If something still depends on it, that will fail.

1 Like
$ sudo pacman -R $(pacman -Qtdq)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.