'Sticky' windows

Hey Endeavourers

I couldn’t help but upgrade to 5.21 today - and I like it so far!

BUT, I noticed my windows now move kinda sluggishly. If I drag Dolphin, for instance, it kinda locks up before moving, moving slightly, then popping back to where it started, and then it moves freely.

I recorded a video onto reddit of the phenomena, but I don’t know if it’s super clear.

Anyone experienced this?

If i had to take a guess, anything “jerky” in animation departament could be caused by low latency improvements of kwin compositor, depending on number of variables…

You should try different modes here (see latency):

2 Likes

Hi beerbelly!

Any chance you could run inxi -Fzx and stick it into a pastebin? I’ve just tried to replicate this on 5.21 /w nVidia and I can’t get the same issue. Knowing your spec and settings would help, but first step could possibly be checking if you’re getting any compositing errors.

Done!
… but currently watching Distro Tube and trying to fix some steam local game files, so my system might look slightly busy hehe

1 Like

Will be having a look!

Great stuff, thanks. Can you confirm if you get the same issue

a) When nothing else is actively running in the background
b) If you have compositing turned off, i.e. switch to xrender

There’s nothing blatantly obviously bottlenecking, but others may be able to offer additional guidance. I’d start with graphics config/drivers and work down. :slight_smile: For what it’s worth, I’m running an RTX3070 with nvidia drivers and not having the same issue on compositing under OpenGL 2.0

They cost a small car here in Denmark because of scalpers :laughing:

I’ll return in about 30 mins when everything is done and nothing is running!

1 Like

will be another 10

Tested with Xrender - no issue

Playing with advanced settings gets me pretty close to how it was.

2021-02-17_19-06

There’s definitely an issue, I’m seeing reports of it elsewhere, so may need to hang tight while this is looked at.

I made another video where I think the movement is more clear

Interesting! I don’t use wobbly windows, but I temporarily enabled it and can replicate what you’re seeing. This isn’t something I could pick up on all my windows are either maximised or minimised. Sure these teething problems will be fixed in the upcoming point releases if the devs know about them.

If you get a chance and you’re comfortable doing so, it would be a huge help if you could log your issues via https://bugs.kde.org/ - I can’t see a similar bug logged currently, but my keyword search has been minimal. Thanks!

Done! Hopefully theyll see it! :smile:

@beerbelly
I use wobbly windows and magic lamp. Two of my favorite things i like about plasma because it makes it smooth and fluid & responsive!

Screenshot_20210218_131136

There is no way with the hardware you are showing that it should not be as responsive as mine. I also have the Nvdia GTX 1060 and Intel i7 8086K.

I would say that something else is going on with your set up because the Nvidia installation looks all correct.

Mine … . i can shake the window and it moves as fast as i can shake it or drag it. It is fluid and responsive and translucent.

https://bugs.kde.org/show_bug.cgi?id=433187

They came back, and it looks like they’re working on it!

2 Likes

Good news my guys! Plasma 5.21.1 is here, and the sticky windows are fixed! Everything is running smoother than ever!

1 Like

I’ve just tested it. Ahhhh, that’s how it’s supposed to be…! :smiley:

Feels so smooth, doesn’t it? :smiley:

Probably pure pseudo, but have they done something to the font rendering? My basic 1080p monitor looks super sharp

My fonts look the same, but running on a 144hz monitor, it’s like butter, so smooth.