Steam (Pacman/Yay) no longer launches

Hopefully you guys are having a good day,

Keeping it short and sweet, I try to launch steam and it returns the following error:

steam.sh[3056]: Running Steam on endeavouros rolling 64-bit steam.sh[3056]: STEAM_RUNTIME is enabled automatically setup.sh[3128]: Steam runtime environment up-to-date! steam.sh[3056]: Can't find 'steam-runtime-check-requirements', continuing anyway [2022-10-14 15:58:27] Startup - updater built Jun 7 2022 03:18:19 ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt". Installing breakpad exception handler for appid(steam)/version(1665100899) SteamUpdateUI: An X Error occurred X Error of failed request: BadValue (integer parameter out of range for operation)

I have attempted the following fixes, most of them stemming from these two forum posts on the arch wiki and endeavour respectfully:

https://bbs.archlinux.org/viewtopic.php?id=273350

Simply uninstalling then installing steam via these sets of commands:

sudo pacman -Syy sudo pacman --remove steam sudo pacman -S steam

Resetting steam-runtime:

 steam-runtime --reset 

Running on the lts kernel (5.15) instead of the normal kernel (6.0)

Checking to see if my NVIDIA drivers were out of date, and then reinstalling them.

local/egl-wayland 2:1.1.11-2 EGLStream-based Wayland external platform local/lib32-nvidia-utils 515.76-1 NVIDIA drivers utilities (32-bit) local/libvdpau 1.5-1 Nvidia VDPAU library local/libxnvctrl 520.56.06-1 NVIDIA NV-CONTROL X extension local/nvidia-dkms 520.56.06-1 NVIDIA drivers - module sources local/nvidia-hook 1.0-1 pacman hook for nvidia local/nvidia-inst 1.2-1 Script to setup nvidia drivers (dkms version) in EndeavourOS local/nvidia-installer-common 1.3-1 Common scripts for nvidia-installer-dkms and nvidia-inst local/nvidia-installer-db 2.5.8-1 Database for the script to setup nvidia drivers in EndeavourOS local/nvidia-installer-dkms 3.5-1 Script to setup nvidia drivers (dkms version) in EndeavourOS local/nvidia-settings 520.56.06-1 Tool for configuring the NVIDIA graphics driver local/nvidia-utils 520.56.06-1 NVIDIA drivers utilities
(Currently running a 3060ti)

Any help is appreciated, and I am not in a rush for a response. Have a good weekend.

(PS, I haven’t posted on a forum for years, so apologies if my bbcode looks awful and I can’t edit my post)

Edit 1: Forgot to mention, here are the results for checking the lib32 drivers:

pacman -Ss lib32-nvidia-utils multilib/lib32-nvidia-utils 515.76-1 [installed] NVIDIA drivers utilities (32-bit)

Edit 2: Was asked to provide the logs, they are linked down below

Hardware: https://clbin.com/6r5Vc
Boot: https://clbin.com/s64MH

Once I figure out how to post the rest of the logs neatly, I will make another edit.

Edit 3: Figured out how to post logs without it becoming unruly.

pacman.conf - https://clbin.com/Wcg42
Xorg.0.log - https://clbin.com/Ji62I
pacman.log - https://clbin.com/yL8FX

Also was able to find another post with similar issues. The pattern seems to be either a partial upgrade of a driver or something out of sync.

Edit 4: Forgot to mention, this start after I completed a kernel upgrade a couple of hours prior to posting to the forums.

Hopefully this helps. Thank you for reading.

Welcome to :enos: forums!!
:enos_flag: :rocketa_purple:

Please post logs as per
https://discovery.endeavouros.com/forum-log-tool-options/how-to-include-systemlogs-in-your-post/2021/03/
for us to have enough information to help you

The essentials have now been posted, I will post the rest once I make sure its not a huge ugly wall of text.

1 Like

Solved. Another update came out 4 hours later and a reboot fixed it. While I was trying to troubleshoot it though, I accidentally deleted a lot of 32 libs, if you are in this situtation, this is what worked for me:

yay steam-native-runtime

Install it. (Make sure you have ‘steam’ installed as well)
Then reset the runtime:

steam-runtime --reset

After that, it works for me, good luck.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.