Steam (pacman) no longer opening

Hello all,

I was unable to launch Steam-runtime today. A single thread showed up in htop, but there was no window. I ran steam --repair per the suggestions of an older Reddit post, and got the following result:[38416]: Running Steam on endeavouros rolling 64-bit[38416]: STEAM_RUNTIME is enabled automatically[38488]: Steam runtime environment up-to-date![38416]: Can't find 'steam-runtime-check-requirements', continuing anyway
[2022-06-02 21:33:01] Startup - updater built Nov 22 2021 22:06:59
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
Installing breakpad exception handler for appid(steam)/version(1653947812)
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

I did try installing steam as a flatpak, which worked fine, but I would prefer to keep using the pacman version if at all possible.

Thank you

tried :

steam-runtime --reset

? just curius :slight_smile:

Just tried that, and got the same error as before, unfortunately

which Video drivers do you have and model gpu ?

its sounds like >

but idk :slight_smile:

I have an Nvidia RTX 3060, and i’m running the 515.43.04 driver.
I tried doing a pacman -Ss lib32-nvidia-515.43.04, as well as shortening it all the way down to 515, but there doesn’t appear to be any package matching that, so I don’t think the fix in that arch post would work

pacman -Qs lib32-nvidia

wil show it locally (with no sudo) -Ss is fromrepo …

only namings are nvidia or nvidia-lts otherwise nvidia-dkms… version dont type it :slight_smile:

just look for lib32-nvidia

The output for that is

local/lib32-nvidia-utils 515.48.07-1
    NVIDIA drivers utilities (32-bit)

This seems to be ahead of my driver. Not sure if that’s what’s causing the issue

and pacman -Qs nvidia , shows the sameversion ?

otherwise looks version mismatch ? nvidia and lib32-nvidia-utils should same

[xxx@xxxx ~]$ pacman -Qs nvidia
local/egl-wayland 2:1.1.9+r3+g582b2d3-1
    EGLStream-based Wayland external platform
local/gwe 0.15.5-1
    A system utility for controlling NVIDIA GPUs
local/lib32-nvidia-utils 515.48.07-1
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.5-1
    Nvidia VDPAU library
local/libxnvctrl 515.43.04-1
    NVIDIA NV-CONTROL X extension
local/nvidia-dkms 515.43.04-2
    NVIDIA drivers - module sources
local/nvidia-hook 1.0-1
    pacman hook for nvidia
local/nvidia-inst 1.2-1
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-installer-common 1.3-1
    Common scripts for nvidia-installer-dkms and nvidia-inst
local/nvidia-settings 515.43.04-1
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 515.43.04-2
    NVIDIA drivers utilities


[xxx@xxxx ~]$ pacman -Qs lib32-nvidia
local/lib32-nvidia-utils 515.48.07-1
    NVIDIA drivers utilities (32-bit)
[artem@artem-pc ~]$ pacman -S lib32-nvidia

By the way, thank you for your patience. I’m very new with this.

what is : pacman -Ss lib32-nvidia-utils

probably need to wait there is somemismatch idk… uf from repo same version as local then reinstall lib32-nvidia-utils

[xxx@xxxx ~]$ pacman -Ss lib32-nvidia-utils
multilib-testing/lib32-nvidia-utils 515.48.07-1 [installed]
    NVIDIA drivers utilities (32-bit)
multilib/lib32-nvidia-utils 515.43.04-1 [installed: 515.48.07-1]
    NVIDIA drivers utilities (32-bit)

I’ve been running sudo pacman -Syu and yay sort of interchangeably, so that may be the issue?

1 Like

best is put # in frond of multilib-testing , and downgrade lib32-nvidia-utils to the proper matching nr’s… sometimes version mismatch is also not nice.


If you have multilib-testing enabled then you should also have testing and community-testing enabled. Otherwise, partial upgrades galore.

Or what Ringo said. :grin:


I ran sudo downgrade nvidia-utils 515.43-04-1 and selected the same version, which didn’t seem to do much, but I’m still getting the same error when I try to launch Steam :cry:

Thank you for the assistance. If you have any other suggestions, I’ll try them out tomorrow

no not downgrade,; edit /etc/pacman.conf fix add # frond of the testing
sudo pacman -Syy
then reinstall that package
otherwise you set on ignore or something then you start a new circle…

testing in arch is not like testing in manjaro :slight_smile:


And mayby you have more lib’s not matching the version …sudo pacman -Syuu wil make it like upstream if you fixed the pacman.conf… but make sure mirrors are right offcourse… if mirror is newer its upgrade also bit since lib32 are newer probably some of them downgrades

I commented out the lib32-testing line in pacman.conf, and then ran sudo pacman -Syy and sudo pacman -Syuu

Thank you so much!


Welcome to EnOS’ community @amarkov!

:enos_flag: :handshake:t5:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.