Steam Issues

This issue has been plaguing me for a while now.

If I leave Steam up for a while (like wake up from a sleep or just leave my computer on) or use the on screen keyboard occasionally, it becomes unresponsive as in it will refuse to open if it’s closed to the task bar or it will let me right click on the task bar icon but it takes forever for the selection menu to pop up and from there you can’t select anything. If it’s open, it just blanks to a white window. This happens randomly. I have tried beta, regular, runtime, native, reinstalling, uninstalling, it happens no matter what.

I ran it from the terminal to see what’s going on but nothing comes up that would be concerning.

That’s the first issue, and this second one may be related.

I do use the steam controller a lot and I have SC-Controller installed. The afformentioned issue happens with or without SC running. I do run it along side Steam occasionally. I have also installed the pack of Udev rules for the controllers. Well, when I want to activate SC-Controller after letting steam use the steam controller exclusively, Steam will not relenquish ownership of the USB (the controller) to SC-Controller. I get the permission error for the USB on SC-Controller.

One last thing, SC-Controller won’t use the controller when I put the computer to sleep and wake it up. I have to manually stop emulation and restart it. Nothing on terminal or systemd.

Check if usb autosuspend is the issue?

I don’t have any suspend rules in etc Udev. Hell, apparently I have no rules in root etc Udev rules folder. I do have rules in the usr lib Udev folder though.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.