Steam Crashing on launch

Trying to launch the steam client, and it immediately crashes with no error messages from the UI.

When I launch it from the the terminal, I get:

❯ steam[8430]: Running Steam on endeavouros rolling 64-bit[8430]: STEAM_RUNTIME is enabled automatically[8502]: Steam runtime environment up-to-date![8430]: Can't find 'steam-runtime-check-requirements', continuing anyway
[2022-12-24 20:47:26] Startup - updater built Jun  7 2022 03:18:19
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
Installing breakpad exception handler for appid(steam)/version(0)
crash_20221224204726_2.dmp[8546]: Uploading dump (out-of-process)
crash_20221224204726_2.dmp[8546]: Finished uploading minidump (out-of-process): success = yes
crash_20221224204726_2.dmp[8546]: response: CrashID=bp-71bced23-6f5b-40e4-a0af-709192221224
crash_20221224204726_2.dmp[8546]: file ''/tmp/dumps/crash_20221224204726_2.dmp'', upload yes: ''CrashID=bp-71bced23-6f5b-40e4-a0af-709192221224''
/home/ptrsdwski/.local/share/Steam/ line 794:  8543 Segmentation fault      (core dumped) "$STEAMROOT/$STEAMEXEPATH" "$@"

When I run it using gdb, I get something a bit more helpful, which is

Program received signal SIGSEGV, Segmentation fault.
0xee01e051 in llvm::orc::ELFNixPlatform::notifyRemoving(llvm::orc::ResourceTracker&) () from /usr/lib32/

I’ve tried reinstalling steam, I tried updating my locale from the arch wiki for steam troubleshooting, I’ve seen a few things about nvidia drivers causing issues, however I’m on a thinkpad t480, which uses an integrated Intel GPU, so I don’t think that applies.

Thanks in advance!

Maybe this will help.

And also this.

Thanks for taking a glance, but these are mentioning the nvidia drivers as the main issue. If I’m using an integrated Intel GPU, that wouldn’t be relevant, right?

Check the coredumps to see if they yield any clues.

$ coredumpctl gdb steam

Edit: Install gdb first if you don’t have it installed.

Looks like I’m getting this from that. Looks like I mistyped the command that I used in the last part of the initial post.

Program received signal SIGSEGV, Segmentation fault.
0xee01e051 in llvm::orc::ELFNixPlatform::notifyRemoving(llvm::orc::ResourceTracker&) () from /usr/lib32/

Can you check which package owns this file?

$ pacman -Qo /usr/lib32/

By the way, please reply to my comment so that I’ll get notified when you reply.

1 Like
❯ pacman -Qo /usr/lib32/
/usr/lib32/ is owned by lib32-llvm-libs 14.0.6-3

So now we have pinpointed which package is causing the error. I guess the next step would be to check steam’s dependencies and see if the version of that package currently installed on your system matches the version required by steam?

1 Like

Hmmmm… As far as I can tell, that package isn’t a dependency for Steam?

❯ sudo pacman -Si steam
[sudo] password for ptrsdwski: 
Repository      : multilib
Name            : steam
Version         :
Description     : Valve's digital software delivery system
Architecture    : x86_64
URL             :
Licenses        : custom
Groups          : None
Provides        : None
Depends On      : bash  desktop-file-utils  diffutils  hicolor-icon-theme  curl  dbus  freetype2  gdk-pixbuf2  ttf-font  zenity
                lsb-release  nss  usbutils  xorg-xrandr  vulkan-driver  vulkan-icd-loader  lsof  python  lib32-libgl
                lib32-gcc-libs  lib32-libx11  lib32-libxss  lib32-alsa-plugins  lib32-libgpg-error  lib32-nss
                lib32-vulkan-driver  lib32-vulkan-icd-loader
Optional Deps   : steam-native-runtime: steam native runtime support

A dependency for steam might depend on that package.

Try re-installing the problematic package and see if it helps.

Hey! That got it! Thanks so much!

So steam works again?

It does! Launches just fine! Can’t believe it was that easy of a fix. lol

That’s great to hear. Happy holidays. And happy gaming.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.