Static & "Spacy" noise when playing audio

Hey guys,

I got a Raze Blade 15 (2022) and install endeavouros on it (without keeping windows).
Everything is going well except for the built-in speakers.
Whenever I play audio, it starts well, but then audio is degrading and one of these things happen:

  • Strong static noise and original audio is barely understandable
  • Strong static noise which becomes “spacy” (could be from a Star Wars movie) when audio is stopped
  • Audio becomes spacy and cuts out after a short moment

Here is the output of inxi -Aaz:

Audio:
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Razer USA
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  Device-2: NVIDIA GA104 High Definition Audio vendor: Razer USA
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:228b class-ID: 0403
  API: ALSA v: k6.6.22-1-lts status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl

Additional information:

  • Bluetooth audio is working well
  • Sound was working well under Windows
  • No sound at all when using NVIDIA Device
  • Same problem when using LTS-Version of EndeavourOS

Which other information would you need to help me?

Thank you for your help.
Cheers,
Schoko

Hey. Some users have been having a recent audio issue since Thursday.

Some additional questions:

  • Is this issue recent - meaning was it working fine before on Linux?
  • How recently did you start trying it on Linux? If it’s since 2022 (if I am interpreting that correctly), then it may be a wireplumber issue.
    * Is sound from your built-in speakers and/or headphones working just fine?

I don t know much about audio but I solved a long time audio problem by running

alsamixer

in terminal and making sure the gain was set to 0 for the master volume. If it s above, or below it can cause problems. (Like it did in my case…)
This is a good resource
https://wiki.archlinux.org/title/Advanced_Linux_Sound_Architecture#Unmute%20with%20alsamixer

Thank you so much!
The default didn’t show a gain for me (just Item: Master). But when selecting my Intel soundcard, I moved all of the channels to gain: 0. This solved my problem!

Though I tried to move them back to see which one it was, but it kept working. :person_shrugging:

Glad it helped. :+1:

I just now realized, that my microphone doesn’t work either.
It appears in the alsamixer, but it’s not recording anything in: PulseAudio Volume Control or when testing it in a website.

Do you happen to know a solution for this as well?

And to answer @ddnn:

  • I installed EndeavourOS only yesterday. 2022 was referring to the version of the notebook.
1 Like

In case it is actually a wireplumber issue, you may need to delete the wireplumber config folder found in .local/state and/or .config.

You can make a backup of the folder first if you’d like to be safe, but the folder is automatically recreated with default settings after rebooting.


image

I’ve renamed the folder and it got recreated, but to no avail.

It should get recreated.

Based on the above, are you saying that you still have an audio issue?

The audio output is fixed since I changed the gain to 0 in Alsamixer.

The internal microphone is still not working even though I renamed the wireplumber directory for it to get recreated.

Hmm. Have you done any updates since?

There have been wireplumber/pipewire updates (2 I think) since March 21st when this issued started. My audio/devices are back to what they were prior to the update.

yup I updated all packages to the latest version. But it didn’t make a change.

Try this:

  • Undo the change(s) made here
  • delete/rename the wireplumber/pipewire config folder(s) again
  • reboot and test

You may also consult the wiki here: https://wiki.archlinux.org/title/WirePlumber

I’ve reset the changes with alsactl init, deleted wireplumber & pipewire and rebooted, but nothing changed.

In alsamixer I can see:

Hmm. So, to confirm: after undoing all the changes, your speakers/headphones are working, but your microphone isn’t - correct?

Also, how many input devices do you see under alsamixer? I’m using pavucontrol, but yours should still look a little similar to this:



The highlighted checkmark shows the default (currently used) device. In this case, NoiseTorch is actually just a noise cancellation app that, once started, can act as a physical device.

That is correct: output is working fine, the microphone is not working.
Everything connected via Bluetooth is also working fine (in & output). I don’t have anything nearby to test the headphone jack.

My pavucontrol looks like this:

In the Alsamixer I can see the following:


Changing values here doesn’t make a difference.

The dropdown for “Headphones Stereo Microphone” says unplugged. There should be another option or two there. What option(s) do you have?



You should have one that says plugged in.

No, this is the only option I have.

For the digital microphone I only have one option either.

I see. So it’s not registering your microphone properly then.

Do you only have the LTS kernel, or do you also have another installed that you could try?

I also have the default Kernel 6.8.2 but it’s the same there. Should I try another one? If yes, which one?