Starting plasma without sddm

Hi there,

I like to start my machine without login manager. So I made the appropriate adjustments in .bashrc and .xinitrc according to Archwiki. In the .bashrc I added these lines:

if [ "$(tty)" = "/dev/tty1" ]; then
   startx
fi

in the .xinitrc these:

export DESKTOP_SESSION=plasma
exec startplasma-x11

This also works so far. But after starting the graphical user interface I probably have wrong dpi values, because font and windows are huge. Neither in the files in /usr/share/sddm/scripts nor in /etc/sddm.conf.d/kde_settings.conf I could find any hints what the problem could be. How can I stop this behavior or what does sddm do that I am missing without it?

EDIT:

└──╼ inxi -G
Graphics:
  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nvidia v: 515.76
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: nvidia
    unloaded: modesetting gpu: nvidia,nvidia-nvswitch
    resolution: 1920x1080~60Hz
  OpenGL: renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.76

EDIT2:
Sorry for my hasty post. After setting this hook in Plasma Font settings…

Force Font DPI to 96

everything works as expected. Sorry again and thank you for now unnecessary reading.