St font is messed up

So ive had this on multiple installs of arch so it has to be something with my hardware. I don’t think i have a hidpi screen its 1080p but i guess i3 thinks it is because its either doing way too much scaling or not enough.

the place where you see it really bad is st as shown in screenshot letter have missing parts and look like they have vasaline smeared on them.

everywhere else text is ok but has a weird sharpness to it which makes me think x is doing too much scaling. i set my ppi(dpi is for print) to 96 in both xresources and my x conf but its still really bad.

any idea’s? oh and yes ive tried multiple fonts so its not that.

I don’t know what you mean by that.
The font is not the actual issue. It’s the font type.
For terminals, a Monospace/Mono type of font is required.
The image shows a font that looks like it is not Mono. Which font is this and which others have you tried?

this is hack. i can switch to dejavu mono. been messing around with setting. 580 is correct. seemed way to big to me

I sincerely can’t understand what you want to say.
I am not a native English speaker. Can you repeat it in Greek? Or else, describe it with more, or different words. :smile:

my uneducated opinion is my screen is scaling too much. when i ran xdpyinfo | grep -B 2 resolution it said my display which is 1080p has a scale of 500mm.

that number seemed high to me but i checked and its correct for a dpi of 96 dpi.

now im wondering if there’s an issue with the font engine. but that doesn’t make sense because then it would be more noticeable.

although my messing with settings has gotten the sharpness of text way down but its still there.

its definitely a scaling issue the question is whats doing it and how to get it to stop.

its not a font problem its a scaling of the font problem. switching fonts won’t fix it

Then it’s OK?

I guess you mean size. What is the real physical size (HxV)?
Post info, please.

xrandr --listmonitors
xdpyinfo | grep -B 2 resolution
inxi -SMGaz

Also, Xorg.log in paste bin.

Your user account (i3 and other dot files) is the source.

Unless you’re a certified Prophet, answer questions. Don’t predict the future. :rofl:

yes size. heres my xorg…conf

Which I didn’t ask, but may become useful if we have the rest of the info. :wink:

don’t need`to be a prophet to know how computers work. and changing a font won’t fix a scaling issue.``

If that was true, the problem would have been solved easily.

I can’t keep asking for info. Either give what is requested, or we have to wait for my :crystal_ball: come back from vacations. :person_shrugging:

1 Like

sorry for some reason it wasn’t uploaded


if the issue is what we see in the screenshot i do not see a geneal scaling issue… the part of the i3 bar looks fine to me… its may simply st that needs a better setup?

1 Like

no its a overall font issue. its not so much a ui issue thats fine. i did more messing with settings and got it to a place where its ok. text isn’t as blurry or overly sharp. i deleted the config that scales bitmapped fonts im not even sure why anyone would try to do that,i set my dpi to 96 in my xorg.conf and messed with other things i forget.

mainly i think deleting bitmapped font scaling fixed it although not all the way things still seem overly sharp to my eye it might not be showing in the screenshot or im just overly sensitive to it.

im still leaning in the direction of i3 isn’t really made to work in a hidpi(not the correct term) screen i guess i have to live with. maybe at somepoint ill install kde again but that would defeat the purpose of having a minimal install.

i do have it installed since ive installed a lot of kde/gnome packages and im assuming kde like gnome is a meta package and installs everything when you install one thing.

The original poster might know this, but fonts in st (the suckless terminal) are hardcoded in the source. See line 8:

If you don’t have Liberation Mono, something will get substituted for it from your available fonts.

Best idea is to find a font you like, and take it with you for each of your st builds.


i know ive changed it. a lot of tweaking has gotten it to a ok point but there is still way too much scaling going on even in kde although much less so. maybe im just very susceptible to this.

also i have an eye condition where i see letters backwards and anything on a black background lit up looks like it has a halo around it. maybe my condition just advanced to the point where its more noticeable now?

I’d suppose that a gradual eye change may now make the situation more annoying is plausible. You could try some other environments just to verify it’s that way in several other desktops. Perhaps bootable ISOs would be the easiest way of various distros with their live environments?

i’ve used my moms mac mini with a old cheapo display and this laptop with gentoo and both have the problem. the funny thing is i have a 2021ish imac 27 that does NOT have it. maybe the bigger screen combined with the higher resolution fixes it for me.

that’s definitely a reason to use it more right now it’s my zoom call machine because of the 1080p camera. i’ve gotten so used to laptops i can’t use a desktop anymore. also the desk chair i have is cheap and not very comfortable.