SSD not recognized (bricked?) after an EndeavourOS install gone wrong

Today, I had an issue while updating my system and I had to shut down the system manually, the error was talking about writing and rotating stuff, I am not exactly sure what it was I must admit. When I rebooted, the boot option wasn’t there anymore so I decided to reinstall EndeavourOS directly. In order to avoid losing my /home data, I chose to keep it and format my other partitions but keep them the same size and everything (I had /, /efi and swap as well as the /home partition which I kept). I then set the same name for my user as usual, and I launched the installation.
Pretty quickly, the installation gave an error while installing. I decided to try again, this time by manually deleting /, /efi and swap and then just rebuilding them from scratch, but now my SSD (which had all my data) is not recognized anymore. I thought this was an error, so I went to the BIOS, and the SSD isn’t there anymore. I also tried using sudo fdisk -l but to no avail. Did it brick my SSD? Is there any way to recover anything? Is my SSD dead?

I am using a Lenovo Ideapad Gaming 3 if that helps.

first: sry to hear from your issue.

If you keep your home partition you will need to rename old users folder to be able to use the same username for the new install… you can copy files and configs back later to the new created users home folder.

Also if you may setup something wrong this will not harm the Hardware itself, only the data can get erased same for partitions and use partition scheme.
If install fails caused by reusing home with the same username it would be after formatting the other partitions but before bootloader creation. with this you would not be able to boot but it should show up on partition managers. Or with command line: sudo fdisk -l or lsblk -f

The SSD does not show up when using fdisk -l or lsblk -f, the only thing that shows us is the live USB from which I am doing this. Likewise, my SSD does not show up on the BIOS.

Could be Bios has reset itself? And defaults using RAID of some kind?

Is there a way to check this?

easiest way is to check Bios settings for settings related.
If the drive is not showing up at all with lsblk and fdisk … it could be also hardware defective or loose connection… but as of thats a notebook

I didn’t see anything in the bios suggesting that. Actually, in the bios it just says [Not Detected] under hard drive…

sudo hdparm -I /dev/sda

could be tried

I don’t think that’s giving me useful information because /dev/sda is the USB flash drive. /dev/sdb etc. gives me nothing.

Compared to spinning wheel drives, SSD and NVMe die hard when they do. In some case, repairable or at least possible to recover data if you gave them in the hand of professionals.

The only thing you can try is resetting the Bios or more easy: powering device off unplug it from power and wait 5 minutes, do a cold start again to see if it brings back the drive

I will try that. If that doesn’t work I’ll just ask professionals if they can at least recover my data. Thank you!

If disk is not seen by BIOS, there is no point of trying to make OS see it.

Powering off will not do anything as well.

For every laptop there is different BIOS reset procedure, probably invoking pressing power button longer / multiple times.

Other option (if BIOS supports it) is to flash same / newer version using USB stick.

But if original error was about “writing stuff” followed by what sounds as forced powercycle… :sweat_smile:

Feels like SSD died during update, but system was still alive, as loaded in RAM. Or sometimes it is just loose connection, and getting SSD stick in-out would make it alive.

Anyway, good luck!

i see several cases where it was bringing back devices. In case i do not know if device was powered of at all may only rebooted, so this power cycle makes sure clean boot.

But yea in case you already done reboots chance is low.

Chances are high that the ssd is broken.
Only way to be sure is to try it on a other pc if you have one that is. If it does get recognized on a other pc use a tool like (G)parted to clear all partitions on it, BUT not before you backup anything that is important to you!
Put it back into your laptop, still not recognized? a bios/uefi or firmware problem is likely the cause.

If the ssd is not recognized by bios/uefi it is impossible to do anything with it or perform checks on it .

1. Check BIOS Settings:

  • Ensure that the SSD is properly connected. Sometimes, reseating the SSD (disconnecting and reconnecting it) might help if it’s a connection issue.
  • Check if the SSD is visible in the BIOS. If it’s not appearing in the BIOS, it could indicate a hardware problem.

2. Physical Inspection:

  • If possible, check the physical connections of the SSD. Make sure it’s securely connected to the motherboard and power supply.

3. Try Another Computer or External Enclosure:

  • If you have access to another computer or an external USB enclosure, try connecting the SSD to see if it can be detected. This helps determine if the issue lies with the SSD itself or with the motherboard/BIOS.

4. Data Recovery Software:

  • If the SSD is recognized in another system or enclosure, immediately attempt to recover data using data recovery software. Tools like testdisk or photorec can help recover partitions and files, even if the partition table is damaged.

5. SMART Status:

  • If the SSD is detected in another system, check its SMART status using tools like smartctl. This can provide insights into the health of the SSD and whether it has encountered any critical errors.

6. Consider Professional Data Recovery:

  • If the SSD remains undetected and you have critical data that needs to be recovered, consider contacting professional data recovery services. They have specialized tools and expertise to recover data from malfunctioning storage devices.

7. Warranty Replacement:

  • If the SSD is under warranty and you suspect it’s faulty, contact the manufacturer for a warranty replacement.

Given that the SSD disappeared from both the system and BIOS after encountering installation errors, it’s possible that there was a critical failure, potentially related to the installation process. However, without physical inspection and further diagnostic steps, it’s hard to definitively say whether the SSD is completely dead or recoverable.

In summary, start with checking physical connections and BIOS detection. If detected elsewhere, focus on data recovery immediately. If not detected anywhere, consider professional assistance or warranty replacement.

As of @mayumin said already the hard drive is not detected in the Bios/Firmware there is no way to be able to use any tools on the drive itself.

The only best bet-try would be indeed to pull of the drive and check what it shows on another machine.

But same same @mayumin already said he will give it to a professional.
So case closed for now, we can hope only for the best and wait if @mayumin give some feedback :wink: