Spontaneous system freezes

Hi everyone, hope you’re doing well. I’ve been using EndeavourOS for a while now and it’s been a blast. However, very recently I’ve started experiencing something that hasn’t happened (to me) in any distro before…

(This is the KDE version of the 2021.04.17 release).

You see, when I turn on the computer and some time passes by, even if I’m doing something or not, the whole system freezes: everything gets frozen, there’s no movement and I can’t do anything (there’s nothing that can be done, the system is unresponsive). I suspect the only thing that can be done is shutting it down, because I’ve waited for some time but nothing seems to happen.

I’ve barely installed anything, just about 6 programs and I haven’t tinkered with anything critical to the system. Also, I’ve tried reinstalling the OS three times now, and this ends happening a while after I’ve settled my things, around 3 days or so…

I hope this isn’t too bothersome, thanks a lot in advance :slight_smile:

1 Like

Welcome on board!
First thing to check is overheating of hardware. You don’t say whether this is a laptop or a desktop system…but if a desktop then it is usually very easy to check and clean fans.

Just guessing, are you using nvidia graphics? Need more infos about your system… click on the top bar, help, forum logtool, how to post your info in the forum.

Hi there, sorry for not specifying but I’m using a laptop. I’ve checked but there aren’t signs of overheating. The laptop is relatively new and it’s pretty clean overall, also there aren’t any weird sounds.

1 Like

What does inxi -Ga tell you?

This is what just came out:

Device-1: Intel Iris Plus Graphics G1 vendor: Hewlett-Packard driver: i915
v: kernel bus-ID: 00:02.0 chip-ID: 8086:8a56 class-ID: 0300
Device-2: Quanta HP TrueVision HD Camera type: USB driver: uvcvideo
bus-ID: 1-5:2 chip-ID: 0408:5365 class-ID: 0e02
Display: x11 server: X.org 1.20.11 compositor: kwin_x11 driver:
loaded: intel unloaded: fbdev,modesetting,vesa
resolution: <missing: xdpyinfo>
Message: Unable to show advanced data. Required tool glxinfo missing”.

Hi, I’ll try providing more information. Since this is a casual laptop, there is no proper graphics card, it’s just the integrated solution that comes with the processor, which in this case is an Intel Core i3-1005G1.

Running inxi -Fxxc0z --no-host:


Kernel: 5.12.5-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM
Distro: EndeavourOS base: Arch Linux
Type: Laptop System: HP product: HP Laptop 15-dw2xxx
v: Type1ProductConfigId serial: Chassis: type: 10 serial:
Mobo: HP model: 85F3 v: 40.19 serial: UEFI: Insyde v: F.01
date: 02/10/2020
ID-1: BAT1 charge: 22.9 Wh (59.5%) condition: 38.5/41.0 Wh (93.9%)
volts: 11.5 min: 11.3 model: COMPAL PABAS0241231 serial:
status: Discharging
Info: Dual Core model: Intel Core i3-1005G1 bits: 64 type: MT MCP
arch: Ice Lake rev: 5 cache: L2: 4 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 9524
Speed: 1218 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 1218 2: 1336
3: 1304 4: 1227
Device-1: Intel Iris Plus Graphics G1 vendor: Hewlett-Packard driver: i915
v: kernel bus-ID: 00:02.0 chip-ID: 8086:8a56
Device-2: Quanta HP TrueVision HD Camera type: USB driver: uvcvideo
bus-ID: 1-5:2 chip-ID: 0408:5365
Display: x11 server: X.org 1.20.11 compositor: kwin_x11 driver:
loaded: intel unloaded: fbdev,modesetting,vesa
resolution: <missing: xdpyinfo>
Message: Unable to show advanced data. Required tool glxinfo missing.
Device-1: Intel Smart Sound Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:34c8
Sound Server-1: ALSA v: k5.12.5-arch1-1 running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.28 running: no
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus-ID: 01:00.0
chip-ID: 10ec:8168
IF: eno1 state: down mac:
Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtw_8821ce v: N/A port: 3000
bus-ID: 02:00.0 chip-ID: 10ec:c821
IF: wlan0 state: up mac:
Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb
v: 0.8 bus-ID: 1-10:3 chip-ID: 0bda:b00a
Report: This feature requires one of these tools: hciconfig/bt-adapter
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 bus-ID: 00:17.0 chip-ID: 8086.282a
Local Storage: total: 238.47 GiB used: 16.85 GiB (7.1%)
ID-1: /dev/nvme0n1 vendor: SK Hynix model: BC511 HFM256GDJTNI-82A0A
size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 serial:
ID-1: / size: 42.96 GiB used: 16.77 GiB (39.0%) fs: ext4
dev: /dev/nvme0n1p7
ID-2: /boot/efi size: 256 MiB used: 85.7 MiB (33.5%) fs: vfat
dev: /dev/nvme0n1p1
Alert: No Swap data was found.
System Temperatures: cpu: 27.8 C mobo: 10.0 C
Fan Speeds (RPM): N/A
Processes: 179 Uptime: 35m Memory: 7.56 GiB used: 1.88 GiB (24.9%)
Init: systemd v: 248 Compilers: gcc: 11.1.0 Packages: pacman: 973
Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.”

Hope this is enough information.

So maybe ‘yay mesa’ and installing the mesa library will help. It shouldn’t be the cause of the lock ups, though.
How long will the laptop run on the Live USB stick?

1 Like

I’ll try performing that command, I had understood that there might be some problems with this Intel Mesa Graphics, since they are new.

The laptop actually runs the OS from its hard drive, but the systems just freezes completely, spontaneously and frequently. It’s hard to tell when it crashes, but it could be from anything. It lasts from two minutes to five, but as I said, it’s completely random…

Sure, however if there was any issues with the storage device in the laptop, then running it from the USB rules that out straight away. However, if the lock ups continue, then there is possibly an issue with the mainboard and the kernel.
Also on the harddrive you could load the LTS kernel, as that may be better suited to this particular machine (although it looks well suited plain-jane hardware).

1 Like

A journalctl could help identifying the issue if you record the time the freeze happened.

1 Like

I don’t really think there could be issues with the motherboard, since I also run Fedora and Windows in other partitions, and they run just fine.

I thought about the kernel situation, but I didn’t want to meddle into that because I feared (and still kinda fear) that it could get worse. But if it continues this way, I guess I’ll try loading the ‘core/linux-lts’ kernel.

Just fyi, you may know this but endeavour os has a nifty tool “akms” you can install easily the lts kernel and corresponding linux lts header. At boot you can then choose either or. If it doesnt work, just reboot into the other…

Yeah, I saw it on the Welcome Screen around an hour ago. I’ve wanted to see if there was something set on ‘Testing’, but then it froze and had to shut it down.

I’ve set the ‘core/linux-lts’ kernel just in case. Also, since almost an hour ago, I’ve been using this computer on the EndeavourOS partition and it hasn’t froze in a while, which is a bit unusual… I ran ‘yay -S mesa’ as onyxnz suggested, maybe that helped with the issue?

I’d echo this, if you haven’t already, some information on what’s happening just prior to the freeze would be really helpful. (And welcome to EOS! :slight_smile: )

journalctl -b

Did you remove xf86-video-intel

sudo pacman -R xf86-video-intel


1 Like

Hi there, hope you’re doing well. I considered trying this at the time that Zircon34 suggested me to do so. However, I don’t recall the exact time when the freezes occurred and to be honest, I don’t really know how to share it, because it seems like a lot of text though… Could you tell me how to properly share it?


I’ve done it right now. Thanks.

I haven’t seen any noticeable differences, maybe the only thing is that the Konsole window was resized from its previous default size. Could you tell me what does this command do? Just out of curiosity (and also to try to learn, of course).

Please check the link. This link can also be found on top of the forum page under help. It explains journalctl and pastbin to post a link with the info.

In a nutshell linux records different events from boot up to running your system and you can identify error messages to troubleshoot the culprit for your system freeze.

Edit: or did you mean the remove command from @ricklinux

Glad that your issue seems fixed.

1 Like

I’ll try reading more carefully, since it seems that I’m not getting the whole information. Then I’ll try using pastbin to show what the journal has.

But yeah, weirdly enough, since yesterday that I tried the ‘yay -S mesa’ there hasn’t been any single struggle nor system-wide freeze. I don’t know if it has been fixed, but it’s been working well.