Speaker not work (but yes with headephone connected)

Hi, I’m a new endeavouros user, I’ve a problem with my laptop, practically…after the OS installation, tree month ago, I noticed that the speaker not work, but the strange thing is, the speakers not work normally, in fact if I start a new youtube video (as example) the audio not work, but if I connect the headphones, the audio work (inside headphones) but simultaneously the audio is played even with speaker (but the audio is very low), and if i try to disconnect the headphones the audio goes back to not working (while, the system microphone not worked never). Before the endeavouros installation, I had windows 11 (and this is the motivation that the change OS) and with windows 11 the speakers worked correctly. the technical specifications are:

the laptop is Huawei Matebook D14.

Kernel: 6.2.2-arch1-1 arch: x86_64 bits: 64
Desktop: KDE Plasma v: 5.27.2 Distro: EndeavourOS
Type: Laptop System: HUAWEI product: BOD-WXX9 v: M1010
Mobo: HUAWEI model: BOD-WXX9-PCB-B4 v: M1010 serial:
UEFI: HUAWEI v: 2.29 date: 04/21/2022
Info: dual core model: 11th Gen Intel Core i3-1115G4 bits: 64 type: MT MCP
cache: L2: 2.5 MiB
Speed (MHz): avg: 1335 min/max: 400/4100 cores: 1: 1354 2: 1340 3: 1334
4: 1315
Device-1: Intel Tiger Lake-LP Smart Sound Audio
driver: sof-audio-pci-intel-tgl
Sound API: ALSA v: k6.2.2-arch1-1 running: yes
Sound Server-1: PipeWire v: 0.3.66 running: yes

reading another forums, I read that, to resolve the problem, was necessary install even the linux-header, but even installing the header the problem is still there

if are need more specifics, tell me!

1 Like

Welcome to the forums! :v:

The speaker and headphone have volume settings stored separately. Make sure the audio is not muted. It might be enough only to play with the volume controls. You didn’t say if you’re using external equipment connected via Bluetooth. If so I don’t know what to tell you because such a thing doesn’t work on my computer… but it shouldn’t have required installing Linux headers or anything like that.

Thank you to the welcome,
I have been play with the volume (with alsamixer) but via this interface I can see that the speaker volume is strange, in fact that is set on 00 and I can’t update that, unlike the audio via headphones, where the volume can be changed.
PS. the headphones are via cable and not bluetooth.

I asked if the speakers were connected via Bluetooth, not the headphones.

But your latest answer is a hint that the speakers are those built into the computer.

That’s strange, I run “alsamixer” and lets me use the arrow keys to change the master volume, and I don’t have headphones connected.

Yes, in fact the strange thing is that with headphones connected the speakers volume is muted, but if I disconnect the headphones the volume is enable but the volume is not changable