Sound problem: a strange "wheezing" all the time

Hi there,

Something strange is happening with my laptop since a few days.

I am running EOS , and a strange “wheezing/sizzle” is coming from the speakers all the time.

Well, this happes when there’s no sound being played. If I start Spotify and play some music, for example, the strange sound disappears.

And, something I also found very strange: when I open the default Gnome settings app, the “wheezing” also disappears.

Anyone has some idea about this?

Thanks in advance for any help.

  Device-1: Intel CM238 HD Audio driver: snd_hda_intel
  Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel
  API: ALSA v: k6.4.7-arch1-1 status: kernel-api
  Server-1: PipeWire v: 0.3.76 status: active

Hi again,

So, guys, I am posting this here case anyone experience the same problem.

I found a solution through this article. The problem disappeared immediately after I save the modifications in the power_save file. :slight_smile:

1 Like

Yeah, this is a pretty common problem with realtek/intel HDA soundcards. Frankly, this setting should be off by default. Hiss and wheezing noises are the less annoying forms of manifestation. On some HDA devices, it produces transient spike noise loud enough to physically damage speakers / ears.

Oh, this is very sad.

Well, very happy here with that solution. That noise was annoying me.

Thank you for this. I had the same problem since I updated the kernel a few days ago. Interesting. the lts kernel didn’'t cause this issue.

You’re welcome.

Well, now I just discovered that the modification is lost always when I reboot the machine.

Maybe I need to create some kind of script to be executed at boot times.

Yes the problem reoccurred after a reboot :frowning:

Hi again,

So, I’m not specialist, but I think I solved the problem.

Just adding the following to the crontab, so the file is filled with 0 each time we boot the machine:

@reboot root echo 0 > /sys/module/snd_hda_intel/parameters/power_save

Hope this helps. :slight_smile:

Thanks Reiner, I use systemd instead, so will need to do some research to implement this at boot time. Presently I am just using the lts kernel without any issue.


Hopefully you’ll find a solution. :wink:

1 Like

Yes, the solution for me was in a comment from the link you gave :smile: -) :
…add the following rules:


ACTION==“add”, RUN+=“/bin/bash -c ‘echo 0 > /sys/module/snd_hda_intel/parameters/power_save’”

No need to set it on each boot, to make the change permanent, create a config file:


with the content of:

options snd_hda_intel power_save=0
1 Like