Sound on Thinkpad running Endeavour not working

I’m nooberific! :grin:

1 Like

@Kaz
what does this show?

pacman -Q grep | alsa

do you mean pacman -Q | grep alsa?

Ya sorry…i typed it wrong. Doh!

Ok. The result of that is:

alsa-firmware 1.2.1-2
alsa-lib 1.2.3.1-1
alsa-plugins 1:1.2.2-2
alsa-topology-conf 1.2.3-1
alsa-ucm-conf 1.2.3-2
alsa-utils 1.2.3-1
zita-alsa-pcmi 0.3.2-3

Okay so now that you ave sound working does this show anything since alsa is installed?

alsamixer

Okay, so i see far right automuted mode enable and i see mic mute-Led mode say’s follow Mute?

I’m not sure if you unmute the automute and see.

Edit: I think you have to click on it and press mm?

That doesn’t work for me. For me, clicking on it doesn’t do anything. Scrolling, however, changes the volume. For me it’s just a cli and not a gui.

On the right it shows auto-mute i think you have to select it somehow and press mm to unmute

Edit: Sorry use the right arrow key to scroll over to it and press mm

When I select auto-mute mode it gives me two options. Enabled and disabled. The mic doesn’t work either way.

Does it have a switch? Mechanical…old skool. :sunglasses:

1 Like

No. It has a built in webcam cover though (which has no effect on the mic)

Bye :hugs:

:sleeping:

1 Like

@Kaz
Do you have the sof-fimware installed?

pacman -Q sof-firmware

Can you post this?

arecord -l

Also try the F4 key as it is the Mic mute led

Edit: That may be the hard control that @Elloquin was asking? Maybe?

No, it’s not installed.

**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC285 Analog [ALC285 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

What about amixer -d