Something went wrong, please help me fix it

Friday I updated the system and something went wrong. System become unresponsive and restart didn’t helped. When login screen appears all seems to work fine, but after login I can barely move the mouse. I spent 10 minutes to get this screenshot:

Apparently all my cpu cores are at 100% which causes the problem. What is the best way to fix it, and what exactly I need to fix ??

I assume that I need to login to KDE plasma (X11)’ instead of KDE plasma (wayland) but I don’t know how to do it?

thank you in advance for any tips.

1 Like

To log into X11 on SDDM (the screen you use to login) you should see on the bottom left an option to change the Session (if you are using the default Breeze theme for SDDM)

As for your issue you will need to post more information about your system. I probably won’t be able to help much more but it will help others to help you further.

https://discovery.endeavouros.com/forum-log-tool-options/how-to-include-systemlogs-in-your-post/2021/03/

ah thanx, I switched to x11 and now works fine, but I need to figure out what happened and how to prevent this in the future

Cool, have a read of the link I posted and share some information about your hardware etc, at the bottom it will show you how to post it on here

For the last two day I try to upgrade my OS without success. It takes a lot of time dealing various stuff until everything freezes. Here is the screenshot when OS become unresponsive.

I can restart my PC and then OS will start to work again and I can check some logs, but I don’t know which ones can help with this situation?

Could you run

sudo pacman -Syu

and post the whole terminal output.

?

No screenshots please. Just copy, paste and press Ctrl-E to format.

[uros@uros-eos ~]$ sudo pacman -Syu
[sudo] password for uros: 
:: Synchronising package databases...
 endeavouros is up to date
 core                                                                                                              134,0 KiB   876 KiB/s 00:00 [---------------------------------------------------------------------------------------] 100%
 extra                                                                                                               8,4 MiB  9,36 MiB/s 00:01 [---------------------------------------------------------------------------------------] 100%
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Package (19)                      Old Version  New Version  Net Change  Download Size

core/audit                        4.0-1        4.0.1-2        0,02 MiB       0,39 MiB
extra/fwupd                       1.9.14-1     1.9.15-1       0,01 MiB       5,45 MiB
core/gnupg                        2.4.4-1      2.4.5-1       -0,09 MiB       2,68 MiB
core/iproute2                     6.7.0-1      6.8.0-1       -0,05 MiB       1,09 MiB
extra/keepassxc                   2.7.6-3      2.7.7-1        2,27 MiB       8,52 MiB
extra/libpaper                    2.1.3-1      2.2.5-1        0,03 MiB       0,04 MiB
extra/libqalculate                4.9.0-2      5.0.0-1        0,24 MiB       2,77 MiB
core/libunistring                 1.1-2        1.2-1         -0,01 MiB       0,65 MiB
extra/libunwind                   1.7.2-1      1.8.1-1        0,69 MiB       0,18 MiB
core/openssh                      9.6p1-3      9.7p1-1        0,01 MiB       1,12 MiB
extra/plasma-workspace            6.0.1-1      6.0.1-2        0,00 MiB      20,30 MiB
extra/python-beautifulsoup4       4.12.2-1     4.12.3-1       0,04 MiB       0,27 MiB
extra/python-cssselect            1.2.0-3      1.2.0-4        0,00 MiB       0,05 MiB
extra/python-importlib_resources  6.1.2-1      6.1.3-1        0,00 MiB       0,03 MiB
extra/python-more-itertools       10.1.0-1     10.2.0-1       0,01 MiB       0,10 MiB
extra/python-platformdirs         4.1.0-1      4.2.0-1        0,01 MiB       0,03 MiB
extra/python-pluggy               1.4.0-1      1.4.0-2        0,00 MiB       0,04 MiB
extra/python-pyparsing            3.1.1-1      3.1.2-1       -0,01 MiB       0,21 MiB
core/shadow                       4.14.6-1     4.15.0-1       0,00 MiB       1,14 MiB

Total Download Size:    45,07 MiB
Total Installed Size:  139,50 MiB
Net Upgrade Size:        3,16 MiB

:: Proceed with installation? [Y/n] 

1 Like

This looks fine for updating the packages from official repos.

Go ahead and update!

Probably the problem is with some AUR package.

But let’s take it step by step!

yes, this works. Upgrade is done. So, the problem is with yay (aur) upgrade?

Could you post pacman -Qm to see what packages you have from AUR?

apg 2.2.3-5
authy 2.5.0-1
authy-debug 2.5.0-1
brave-bin 1:1.63.165-1
cewe-fotobuch 7.4.2-1
cryptomator-bin 1.12.3-1
dropbox 191.4.4995-1
electron25 25.9.8-4
freeoffice 1068-1
git-cola 4.5.0-1
greenflare 0.98.1-1
hollywood 1.21-7
khotkeys 5.27.10-1
kjs 5.115.0-1
kpeoplevcard 0.1-2
kquickcharts5 5.115.0-1
libtiff5 4.4.0-2
libxnvctrl-470xx 470.239.06-1
lsyncd 2.3.1-9
lsyncd-debug 2.3.1-9
noto-color-emoji-fontconfig 1.0.0-1
nvidia-470xx-dkms 470.239.06-1
nvidia-470xx-settings 470.239.06-1
nvidia-470xx-settings-debug 470.239.06-1
nvidia-470xx-utils 470.239.06-1
pcloud-drive 1.14.4-1
prepros-bin 7.22.0-1
printer-support 1-6.1
python-jaraco.packaging 9.4.0-1
python-polib 1.2.0-1
python-rst.linker 2.4.0-1
python-sphinx-lint 0.9.1-1
python-ua-parser 0.16.1-1
samba-support 1-7
slack-desktop 4.36.140-1
slack-desktop-debug 4.36.140-1
speedometer 2.9-2
stremio 4.4.165-1
sublime-merge 2091-2
sublime-text-4 4.4169-1
teamviewer 15.51.5-1
zoom 5.17.10-1
1 Like

This is most probably the one causing the problem.

There have been a couple of users having issues related to this package when updating from AUR.

The solution has been to remove it before updating.

Check if something is dependent on it in your system: pactree -r electron25

[uros@uros-eos ~]$ pactree -r electron25
electron25
└─prepros-bin
[uros@uros-eos ~]$ 

When OS become unresponsive in console window is:
CXX obj/content/browser/browser/network_handler.o

maybe some browser is causing the issue? … like brave?

That seems a bit problematic then.

If I were in this situation, and I am not suggesting you should do this, I would remove these packages and update the rest of them.

Updating electron, that is building it from source, will need to download a huge repo since it is based on chromium and most probably consumes much of your system’s resources. That could be the reason why it freezes.

If you want, you could also wait for “second opinions” from more AUR well-versed users.

Hm, thanx for all the help.

I never had problem until now with upgrading AUR packages. If there is no other soulution I will try to remove “electron25” and “prepros-bin” and see what happens.

Probably because you had electron installed as binary from official repos. Now the old version has been dropped to AUR and that is why you need to build it yourself on your system.

As far as I know, there is no way around it. Either your system is capable of building it or you would need to remove it and go on updating the rest of packages.

Hopefully you won’t encounter issues with the others :wink:

2 Likes

Well, no there is no harm for removing it and then install it again. From where I should install it to avoid such problems in the future?

The issue seems to be with prepros-bin.

The version in AUR depend on electron25. So if you want to install prepros-bin it will inevitably pull in electron25.

So it’s sort of a “Catch-22” situation.

1 Like

I removed prepros-bin with all dependencies and upgrade went through without problem. Now my system is up to date.

I noticed another minor problem with Krusader. I can’t login to any smb, ftp, sftp address anymore because I get the message “Protocol not supported by Krusader”. I noticed this before removing prepros with all dependencies so it shouldn’t be connected.All tested connections work fine using Dolphin.

I read that Krusader doesn’t support those protocols by default and you need to install some additional packages but all worked fine before last upgrade few days ago. Aynone know how to fix this?

I already have kio but still doesn’t work:
extra/kio 6.0.0-2 (kf6) [installed]
Resource and network access abstraction

It looks like krusader still requires qt5, so it uses kio5 (hard dependency).

You likely need the kio5-extras package (optional dependency).

2 Likes