Something is wrong with steamwebhelper


this is the first time i encountered this problem. i had no problems with this window during my time on nobara.

to clarify things a bit more, so when i make a purchase on steam, usually another window pops up when confirming the payment for transaction (gcash in this case), it opens an external alipay window and you scan the qr code to complete the payment.

i was planning to buy a few games today and this problem showed up. it’s either the window doesn’t show up or it’s just transparent. when i alt tab, i can perfectly see the contents of the window but nothing shows up when im on the actual window.

Try steam-native or but from the browser

do i replace it with the steam that i have or just install it?

just install this, no need to remove anything https://archlinux.org/packages/multilib/x86_64/steam-native-runtime/

you can launch from the menu, it has a dedicated icon

but I think the purchase should work from the browser, if it doesn’t than something is up with gcash or steam

thank you, i’ll try that. i have no problems with using steam on browser but i just like to separate things. i like doing steam stuff from steam app directly instead of just going to the browser yknow.

There is a lot wrong with steamwebhelper, that’s nothing new :sweat_smile: used to be i’d sometimes run steam without webhelper but i think it can’t be done anymore.

Since you seem new (welcome btw) let me give u a few tips.

1: Your issue is a window not rendering, it’s possible that it’s a wayland issue, i see you’re using plasma, you should on your login screen be able to choose between plasma x11 and plasma wayland, see if the issue still occurs on x11 or not. If it doesn’t, the problem is with wayland/xwayland. It’s possible that life on x11 will be a lot less painful for you in general, if one works better for you than the other there isn’t much in the way of reason to use one over the other anyways so just use the one that works best in general.
2: First step to solve an issue with a linux native steam game not working on linux is to switch between steam-native and steam (runtime). the difference is that steam-native uses the libraries on your installation to try to run your games, these are generally more up to date, the steam runtime version uses libraries that are shipped with steam which are older but most game devs that publish on steam test their games with so should in theory be more reliable, but they aren’t always.
3: For non-native (proton) games the first step in trying to solve the issue is to change the proton version the game uses. Generally speaking, proton-ge (which you can get from AUR through yay) will work best for most games, but some games specifically work best with older proton versions, which is why steam lets you specify the version.
4: use protondb to check how well you can expect a game to work on linux. If you have problems with a specific game, read the protondb reviews and see if anyone used any tinkering steps that could help you. You can also check the proton github thread for your specific game for even more details if a game proves particularly challenging to run.

thanks for the informative reply. to answer the first point, first thought i had was to switch sessions. i tried to do the same on x11 as well but i still have the same problem.

i have some questions to the second point, which is how do i know if steam-native will need other libraries that i need to install for some games? does it tell me that x library is needed or can it install the missing libraries for me like how wine does sometimes?

third point, i am aware of the proton versions that you sometimes need to use for games to run smoothly/better since sometimes the graphics are whack (stuttering, screen tearing, not rendering properly, etc.). also, coming from nobara, i know of GE’s proton versions so that’s that.

for now i’ll try using steam-native instead. see how it goes for my next purchase.

The package will install all the necessary dependencies, I never had to install anything extra. Also you’re supposed to use proton-ge with steam-native.

is it fine to use proton-up qt instead of downloading it from the AUR?

never tried it, because I compile proton and proton-ge for x86-64-v3