Some tray icons missing (Plasma)

Me again,

I made a fresh install, online, I wanted to try if this ancient laptop can run plasma,
but, I think I made a TOO minimal install, some of the tray icons are missing,

I have the notifications bell, the media player, clipboard, devices (usb), and the printers, that’s it, lol, everything else is missing,

I tried

pacman -S plasma-desktop , it read ‘plasma is already installed’

I could do

pacman -S plasma , but I don’t want the whole stuff, only the missing tray icons,

Can someone point me to the fewest possible packages I need please?


I am not at my computer right now but you plasma-nm and there is also a plasma-pulse I think. Those package names might not be perfect but they should be close

I re-installed EOS, did it offline, and switched to plasma after, in worked ok, but, the discover app only ‘sees’ the flathub repo, not the arch repos, that’s funny.


Make sure you have packagekit-qt5 installed.

Using discover to install/update repo packages is not safe. It uses packagekit which doesn’t support any form of manual intervention which is often required on Arch. You can easily break your system this way.


Yep, that was missing, I installed, now it works, thanks

I use the terminal most of the time, maybe tkpacman or pamac from the aur, it is only when I do not remember the name of the package, but I remember the icon, I resort to discover / gnome software to have a look for the dang icon, that is just me getting older.

And I use discover to look for themes - icons - cursors when I get bored with the themes.

Laters, Thanks.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.