Some doubt regarding eos install

Disable CSM and boot UEFI only.

Edit: As @joekamprad said if Windows is installed in Mbr mode you won’t be able to boot Windows.

hi, you mean change two options ? like “launch CSM” to disabled and “Boot option filter” to UEFI only ?
i no longer have w10 installed, it was on the WD hd and i wiped it to try to install eos, installation runs fine til the end asking me to reboot to conclude install but then i get that message i posted, also if i change to uefi only and disable CSM will i still be able to boot on my older eos install on the samsung hd ?

well i just tried to disable CSM, it gives me a warning saying i have to set launch video policy to “UEFI first” and then reboot to disable CSM, i did that it took like near 3mins just to get on bios settings again, and even so i coundt disable CSM, i got the same warning telling me to set video policy to UEFI first

You can try it and see if it still boots on the samsung. It should if it’s installed in UEFI. If you don’t have Win10 any more then that’s not an issue. If your system is UEFI you should be installing in UEFI mode.

You need to set those others to uefi first.

Launch Storage Oprom policy
Launch Video Oprom policy

i set video policy to uefi first, launch storage doesnt have uefi first option so i left Uefi only instead, boot option filter left as 'Uefi and legacy" still getting the same warning when trying to disable csm

There has to be a way to set it. Have you tried setting the main UEFI settings back to default and then check what it shows. What is the hardware? Maybe i can check the manual.

Edit: Did you try setting boot option filter to UEFI only.

CPU: Intel i5-3470
GPU: NVIDIA GeForce GTX 1650
motherboard: isync-h61 m2 lga 1155
i guess for now i could just create a new plasma user and backup my configs to it, my configs like panel got messed up when updating from plasma5 to plasma6, and since this is an old install i noticed it doesnt have dracut (the older pc here i formated 2 days ago does show dracut on boot), but creating a new user should be enough for me now

Sorry I didn’t notice before. I see from your log both hard drives are installed on dos (Mbr) so you have to use csm with legacy unless you install on all drives using UEFI. ISO has to be booted in UEFI and installed that way.

Edit: So settings have to be correct in Bios in order to boot the ISO in UEFI mode.

so i should change the boot option filter from “uefi and legacy” to legacy only ?

Is your intention to reinstall? I’m a little lost as to what you want to do? Both drives look like they are installed on dos disk using Mbr. If you can get it set to boot the ISO in UEFI then it can be installed that way. Not sure that your motherboard is UEFI even though it shows the settings. :wink: That’s something you’ll have to confirm.

i had 2 options: create a new user on the existing main hardrive to refresh and fix the config issues i had when i made the update from plasma5 to plasma6, or format the other hd i had with windows 10 and try to install eos on it from zero, i decided to format the hd with windows 10 while keeping my older eos isntall in case i need to swap some files or just to better asssist me setting up the new install on the other hd, i used a multilaser dvd to install eos on my older pc here about 4days ago and it worked just fine, so i suspect it might be either something related to mintstick or my usb flash drives being like 5-10yo, i’ve decided to wait to get a portable dvd driver from lenovo and try to use the multilaser dvd i used a few days ago

Okay so i have a better understanding. You said you chose GPT but from the log it shows both drives are installed on dos disk with Mbr.

Model: ATA SAMSUNG HD502HI (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  105GB  105GB  primary  ext4
 2      105GB   500GB  395GB  primary  ext4


Model: ATA WDC WD5000AAKX-0 (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 


Number  Start   End    Size   Type     File system  Flags
 1      1049kB  168GB  168GB  primary  ext4
 2      168GB   500GB  332GB  primary  ext4

So technically they should both boot properly if you boot from one drive or the other. :thinking: