Some CPU temp issues after playing with cpupower and thermald

I can reinstall the system to make sure the hardware is good, but I’m pretty sure it is and in any case, I will do a quick reinstall.

However, some hours ago I did install first a cpupower utility and tried to set EPB value with:
cpupower set -b 6 and cpupower set -b 0
After an hour or so, with noticing some weird temp spike to 50-70c without me doing much and while usually I get around 45-50 in these type of work, I removed it, but the issue remained.
I then tried to install thermald and did exactly as it says on EOS tutorial.
The problem is… it’s been over 12h period now since thermald working, yet I have my fans working almost all the time(not full power though) and cpu temp is going unusual for me even on idle - 55-75c.

I don’t think there’s an issue with my specs, and honestly don’t want you to investigate the issue, but rather give me some ideas and maybe tools of how I can do that myself? Where should I look? What should I install/reinstall?