[SOLVED] X11vnc server start at boot or login using KDE Plasma help

I have Endeavour installed on a system with Kde Plasma.
While Plasma does have a few glitches on this machine, it is running ok, but may need a few tweaks to install everything it really needs similar to what the previous OS did, I’m assuming. just some fyi as themes act a little weird with dolphin and power-devil wasn’t installed. I could have done it bass-actwards somehow too lol
I only thought I’d add that because my everyday system is still running Antergos leftovers and doing fine so I’m still sorting out what’s missing

I’m trying to install x11vnc server to run at boot or login on this other machine as I’m trying to get away from NAS4Free so all my stuff uses the same OS.
It would be nice to have an arch NAS setup install in the new intaller that works similar to NAS4Free…just throwing that out there :stuck_out_tongue:

I have plasma set to auto login, the cmd line works fine to run it, but all the how too’s I’ve tried over the last week have me to a point where I’d very much enjoy thrusting one of my swords through the tower case.

Before I do any said “THRUSTING” Does anyone have a good how to for installing x11vnc server in Endeavour/Arch plasma?

I’ve been through the arch wiki, some I understand, some I don’t, I’m just not finding the correct working examples I need to stop the insanity.

I don’t have a sword but i got a big hammer i use when stuff doesn’t comply with the standards! :wink:
Maybe this might help? https://forum.manjaro.org/t/guide-how-to-set-up-x11vnc-server-for-access-to-the-current-running-session/32525

1 Like

Thankyou for that link as it had both options.

I wanted to start by script, and that cmd line had everything I needed, however I had to remove the -nocursor option as I think it was crashing x11server. I could be mistaken as I was doing things so fast.

The next problem was solving why the script wouldn’t execute at all but did from cmd line, so immediately after threatening to get the 20lb mace I use as a doorstop, I noticed
#!bin/bash was not the proper #!/bin/bash (gaaaaakkk GRABS HEAD, PULLS HAIR)

Thankyou, it works now, but kinda disappointed I didn’t get to use the mace :stuck_out_tongue:

Well I’m happy i could help. I really don’t have any experience with setting this up but i read a lot of stuff and if it makes sense i usually pass it on and let the user go over it and decide for themselves if the info is relevant. Sometimes unless you do it first hand yourself it it hard to understand. I know the Arch wiki probably had you just spinning as it spews technical info and sometimes little help. :slightly_smiling_face:

1 Like