[Solved] Video Playback issue

Depends what the issue is, if a faulty vlc settings removing vlc and reinstall wont help because the settings are stil in .config. if there is a vlc update it can help if there was a bug offcourse. When you dint know the base issue you dont know what is the basic…

I see egl_x11 , which desktop are you using? I know nvidia do use egl streams on wayland these days… Gnome is standard wayland so im curius.

2 Likes

With vlc it usually is (if you compile vlc yourself, there are often other issues, some incompatibilities or again changed options, but then you know, that you have changed something yourself). But this is not only the case with this one program.

Absolutely correct.

But this is not a reinstallation (= same files), but an update or an upgrade, i.e. there are files in different versions, i.e. different files.

Installing over the same thing again is nonsense.

And seriously, I find it very strange to have to explain something like that in a Linux forum (these are not secret details, but logical principles). I expect more than on a Windows forum. A lot more.

I would like to add some more detail.
When I initially had the three monitors hooked up, I could see everything, although the text was quite small on menus and such.

After I got my vesa bracket to attach to my quad mount, I disconnected the hdmi monitor to hang it.

There was some updates, and so a reboot ensued, a couple actually.
The print in the menus, browser and other areas jumped up to a visible level from a distance.

Today I came home to do updates, on my server that’s running endeavour KDE…
I’ve been using KRDC and connecting through ssh with that…it would seem that certain thing have been affected. I had to slightly stretch the screen for the video to update on my end. KRDC acted in the same way almost as VLC being all goofy and what not.
I couldn’t find anything in krdc settings to adjust…“That made any sense”, I did install UlrtaVNC Viewer from the AUR.

Installing UltraVNC did work, however I don’t believe it’s going through ssh because of the port, maybe I missed something, but whats more peculiar is when I installed ultraVNC viewer, the initial setup menu came up in WINE?
I didn’t know things could be installed and ran directly from WINE, having said that, this particular action was done through pamac-aur-git.
I mean it works, I just thought it was odd to see wine running as part of a setup, maybe thats how this thing installs idk, just saying.

I’ve also been through the nvidia x-sever setting tool to look for adjustments as well as
Detect system issues in the welcome launcher, which I saw some things the other day, but it finds nothing now.

Bottom line is, it seems things have adjusted themselves to the way they want to be, but some programs don’t like to play nice with either KDE or Arch to some extent, I’m going to guess it’s KDE so if anyone knows of a multi monitor adjustment tool to tell KDE to play nice, let me know, maybe KDE needs something like this idk, everything else seems to work great visually, just a few tools seem to go all bat crap crazy now that multiple monitors are in use.

UltraVNC says depends on wine so ya it installs with wine. I don’t know much about your set up but i do know that KDE is quirky! :smirk:

Right, it’s a Windows executable. You know something like this from earlier Teamviewer versions, for example. There the .deb packages include wine. Regardless of whether you have perhaps already installed wine yourself.

@MrEd, I’m assuming, you have installed this from AUR, that’s right?

You see, it’s long time unmanaged and a very old version (1.2.1.6, 2017-09-13). I would at least install the current version (1.2.2.4, 2019-03-14) or better the release candidate (1.2.3.0 rc, 2019-11-17).

But only in passing, because you also brought this, this thread has started about the vlc.

cvlc --verbose 2 /path/to/video

will give a verbose output on what happens (if you want to try default vlc again :wink: )
I can use vlc without any issue here on multimonitor setup nvidia drivers and vdpau …

Yeah I was trying to keep it just about vlc, but the issue seemed related.

@joekamprad

I uninstalled vlc-git and reinstalled vlc to try

cvlc --verbose 2 /path/to/video

but before I did, I clicked a video and the bleeding thing worked in vlc lol
xine doesn’t work, but idc :stuck_out_tongue:

Something I did notice though, if I stretch vlc window over half of second monitor, the video disappears and starts to show 3 vlc gui’s almost like it doesn’t know which monitor to display itself on, maybe theres a setting for that in krdc, I’ll play with it more, but vlc issue is solved

So at this point, the fix would be either install vlc-git then vlc again or
when I tried just reinstalling vlc, maybe it didn’t get everything on the uninstall even though the config file was moved?

Thanks for all the help, this gives me some direction if any other video issues happen.

vlc have an option where you can select on which display you want to show fullscreen:

I tried the, but regaurdless of it being on automatic or specific setting, makes no difference.

While I did say it was working, it isn’t without issuses.

It seems it has to open on monitor 1 to start.

I did end up running rour code

cvlc --verbose 2 /path/to/video

here are the answers

$ cvlc --verbose 2 /home/major/Downloads/freetest.mp4

[00007ff1d4004030] mp4 demux warning: elst box found
[00007ff1d4004030] mp4 demux warning: STTS table of 1 entries
[00007ff1d4004030] mp4 demux warning: CTTS table of 151697 entries
[00007ff1d4004030] mp4 demux debug: adding track[Id 0x1] video (enable) language undef
[00007ff1d4004030] mp4 demux warning: elst box found
[00007ff1d4004030] mp4 demux debug: track[Id 0x2] read 157299 chunk
[00007ff1d4004030] mp4 demux warning: STTS table of 1 entries
[00007ff1cc000c80] main input debug: Stream buffering done (500 ms in 0 ms)
[00007ff1d70bcd40] faad decoder warning: decoded zero sample

[00007ff1ac001ec0] egl_x11 gl debug:  extensions: EGL_EXT_buffer_age EGL_EXT_create_context_robustness EGL_EXT_output_base EGL_EXT_stream_acquire_mode EGL_IMG_context_priority EGL_KHR_config_attribs EGL_KHR_create_context_no_error EGL_KHR_context_flush_control EGL_KHR_create_context EGL_KHR_display_reference EGL_KHR_fence_sync EGL_KHR_get_all_proc_addresses EGL_KHR_partial_update EGL_KHR_swap_buffers_with_damage EGL_KHR_gl_colorspace EGL_KHR_gl_renderbuffer_image EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_3D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_image EGL_KHR_image_base EGL_KHR_image_pixmap EGL_KHR_reusable_sync EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_KHR_stream_cross_process_fd EGL_KHR_stream_fifo EGL_KHR_stream_producer_eglsurface EGL_KHR_surfaceless_context EGL_NV_nvrm_fence_sync EGL_NV_post_sub_buffer EGL_NV_stream_metadata EGL_NV_stream_reset EGL_NV_stream_sync EGL_NV_stream_consumer_gltexture_yuv EGL_NV_stream_attrib EGL_NV_sync EGL_NV_system_time EGL_NV_output_drm_flip_event EGL_WL_bind_wayland_display EGL_WL_wayland_eglstream
[00007ff1ac001ec0] egl_x11 gl error: cannot select OpenGL API

[00007ff1ac021a30] main filter debug: looking for video converter module matching "any": 23 candidates
[00007ff1ac021a30] vaapi_filters filter warning: Using SW chroma filter for 1280x720 VAOP -> I420 

[00007ff1ac0013b0] main vout display debug: VoutDisplayEvent 'resize' 1526x720
[00007ff1a8047840] main video output warning: picture is too late to be displayed (missing 58 ms) 

[000055eb43634e40] main audio output warning: playback too early (-40042): down-sampling
[000055eb43634e40] main audio output debug: resampling stopped (drift: 159 us)
[00007ff1a807a7a0] xcb_window window error: X server failure
X Error of failed request:  GLXBadWindow
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  26 (X_GLXMakeContextCurrent)
  Serial number of failed request:  14190
  Current serial number in output stream:  14190

There was so much I just copied the errors and the line before it, but
[00007f24c8001ec0] egl_x11 gl error: cannot select OpenGL API

seemed to be what stuck out to me.

I believe I’ve found the cause of this as video scaling in VLC and KRDC still were giving me crap and would only function correctly on one monitor…

Somehow it would seem that adding the third monitor had changed the Global Scale setting under Display Configuration to 137.5%

Setting this back to 100% fixed everything!

I’ve just been patiently dealing with it and ignore it lol

I happened to notice this setting because updates that affect MY display settings seem to switch my wallpapers around and I have to switch a monitor position to another and back for it to fix, and I happened to look down and saw the global scale setting.

Fixing this setting back to 100% also fixed my conky’s which I thought something else was wrong because they were way off screen and larger, so I’ve had to have them shut off till I got to it, but they did this at that same time adding the third display, I just never put it together until now.

1 Like

I do have a drawback to this, for whatever reason the global scale changed, I loved it as far as Firefox and Thunderbird and the KDE menus where concerned.

I know I can adjust the KDE Dolphin menus, but does anyone have a way to zoom Firefox & Thunderbird? They changed the way addons function awhile back as I’m sure most know, but after they did this and without the global scaleing, how else can I get back large tabs, address bar and what not in side about:config?