(Solved) Vfat not recognised by kernel

Upgraded system 12th October 2019 rebooted and vfat usb drive not recognised - unable to open in thunar. kernel linux-5.3.5.arch1-1-x86_64
Downgraded kernel by following instructions on wiki to linux-5.3.1.arch1-1-x86_64 , rebooted and vfat usb drive now recognised by thunar.
Is this a bug?

is any of these installed

'udisks2 & gvfs (optionally gvfs-mtp, gvfs-gphoto2


problably needed those ?

Worked before upgrade. Didn’t work after. Only thing done to make it work again is replace kernel.???

did you rebooted after te upgrade ?

to answer your question, both gvfs and udisks2 appear to be present according to pacman and yes I did reboot.
Thanks for the interest.

what does this say?

lsmod | grep fat

[terry@terry-pc ~]$ lsmod | grep fat
vfat 24576 0
fat 86016 1 vfat
[terry@terry-pc ~]$

sorry, this is with 5.3.1 kernel that works. you probably mean with 5.3.5 kernel?

with the latest idd

ringo@Konoha ~ % lsmod | grep fat
vfat 24576 1
fat 90112 1 vfat
ringo@Konoha ~ % uname -a
Linux Konoha 5.3.5-zen1-1-zen #1 ZEN SMP PREEMPT Mon Oct 7 19:03:07 UTC 2019 x86_64 GNU/Linux
ringo@Konoha ~ %

my walkman usb device, doesnt show appereantly but get mounted hmmm

sudo file -s /dev/sd*N
(replace *N with device letter and partition number)

I’m obviously a bit of a noob!!
Everything is now working!
Re-installed kernel 5.3.5 to do as ringo suggested and got nothing displayed from " lsmod | grep fat".
Then, did as joekamprad suggested and got
[terry@terry-pc ~]$ sudo file -s /dev/sdb1
[sudo] password for terry:
/dev/sdb1: DOS/MBR boot sector, code offset 0x58+2, OEM-ID “mkfs.fat”, sectors/cluster 8, Media descriptor 0xf8, sectors/track 62, heads 238, hidden sectors 2048, sectors 15106048 (volumes > 32 MB), FAT (32 bit), sectors/FAT 14724, reserved 0x1, serial number 0xd873166e, label: " "
[terry@terry-pc ~]$
then unplugged and replugged usb drive and now working.
So, confused… was it the re-plugging that forced the vfat module to be loaded?
Anyway… now have working kernel 5.3.5.
Thanks to all.

1 Like

sometimes usb hubs went nuts :wink: