(SOLVED) Swap partition fails to mount on boot

Hello.

Did a system update yesterday. Tried to turn on my PC today, only to see this:

[ TIME ] Timed out waiting for device /dev/disk/by-uuid/0f1c6e22-9aa2-4706-b2dd-e753032c0c99
[DEPEND] Dependency failed for /var/log
[DEPEND] Dependency failed for Local File Systems
[DEPEND] Dependency failed for Flush Journal to Persistent Storage
[DEPEND] Dependency failed for /home
[DEPEND] Dependency failed for /var/cache
[ TIME ] Timed out waiting for device /dev/disk/by-uuid/7a0a2ec0-16cc-4419-853a-88d53a36ad94
[DEPEND] Dependency failed for /dev/disk/by-uuid/7a0a2ec0-16cc-4419-853a-88d53a36ad94
[DEPEND] Dependency failed for Swaps.
[ TIME ] Timed out waiting for device /dev/disk/by-uuid/C1B4-C5FE
[DEPEND] Dependency failed for /boot/efi
[DEPEND] Dependency failed for File System Check on /dev/disk/by-uuid/C1B4-C5FE

…oh no

Booted into emergency shell (or whatever it’s called), after fiddling around for a bit it seems like all my partitions/btrfs subvolumes mount fine except for the swap partition (I don’t actually know how to mount swap manually, but everything else mounts fine so it must be a problem with the swap partition).

I masked the systemd unit responsible for mounting swap and now my system boots fine, but I’m not sure what to do next. I didn’t see any explanation why the swap fails to mount in the system logs, the only thing I saw was that the device containing swap timed out.

The only suspicious thing I found was in the output of fdisk -l:

Disk /dev/nvme0n1: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: Samsung SSD 980 1TB                     
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 16384 bytes / 131072 bytes
Disklabel type: gpt
Disk identifier: 8EFD918A-2436-4B3C-A6C1-366AA060D771

Device              Start        End    Sectors   Size Type
/dev/nvme0n1p1       4096    2052095    2048000  1000M EFI System
/dev/nvme0n1p2    2052096 1881418689 1879366594 896.2G Linux filesystem
/dev/nvme0n1p3 1881418690 1953520064   72101375  34.4G Linux swap

Partition 3 does not start on physical sector boundary.

Other observations:

  • My data seems to be fine.
  • btrfs check on root filesystem reports no errors.
  • smartctl -a /dev/nvme0 reports no errors, I also ran smartctl --test=short /dev/nvme0 and it reports no errors either (long test currently in progress).

Possible causes (all of these seem unlikely but I’m kind of grasping at straws here):

  • I ran another update ~3 days ago and it upgraded core/filesystem (2024.01.19-1 → 2024.04.07-1), the kernel (6.8.2.arch2-1 → 6.8.4.arch1-1) and a bunch of other seemingly important things.
  • I installed the powerpanel package from the AUR yesterday. Probably unrelated but hey, it’s the last thing I installed before weird stuff started happening.
  • I did a few “unsafe” shutdowns (holding down the power button) over the last few weeks. Usually because my system would hang for several minutes while trying to do a regular shutdown (I never did unsafe shutdowns during important stuff like system updates etc.). The last unsafe shutdown was a few days ago, but I had several clean shutdowns/reboots since then without any issues.

WTF just happened to my swap partition? How do I figure out what happened and why it happened?

And possibly, how do I fix this?

Have you tried booting the fallback entry?

That’s a good idea, not sure why I didn’t think about it earlier.

Update:

  • Unmasked the systemd unit responsible for mounting swap, just to confirm that the problem still occurs on the normal boot entry
  • Tried booting the fallback initramfs entry, problem doesn’t occur (system boots fine)
  • Tried booting the normal entry again, and it suddenly works.

I’m guessing booting from the fallback entry somehow fixed the swap problem, still not sure what happened but everything works fine now.

Hello @k2aj
welcome to the purple universe :enos: :enos_flag: :penguin_face: :rocketa_purple: :purple_heart:

Little tip, if you want to mark a thread as solved, you don’t have to write it in the title. There is a checkbox :white_check_mark: in the comment that helped you that you can activate :wink:

grafik

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.