[SOLVED] Swap Can't Open

After I updated today , my system says after passing grub that Swap can’t open. If I dmesg there is a message saying “swapfile has holes”. And generally my system is slowed down. Anyone encounter anything similar? Thank you

Welcome, Matt!

This appears to be a bug in kernel 5.7.2. There have been bug reports filed upstream against this issue.

For my part, I dropped back to the LTS kernel for now (until a fix is released), and this allowed swap to be recognized again.

Hope this helps!

Barry

2 Likes

using swapfile ?

1 Like

My understanding (and personal experience) is that it happens with swapfile, not swap partition. Some are reporting that creating the swapfile with dd and not fallocate solves the problem; however, it does seem to be a bug in the kernel that has been fixed and should hit mainline kernel soon. See here:

https://bugzilla.kernel.org/show_bug.cgi?id=207585

Being tracked at arch here:

https://bugs.archlinux.org/task/66921

3 Likes

b.t.w. welcome at the forum! it is a good idea to have LTS kernel installed as a fallback option if something like this happen with latest kernel.

sudo pacman -S linux-lts linux-lts-headers
you can choose LTS on boot menu then

2 Likes

Actually, there is no need for that, as the LTS kernel will become the default entry & will have to choose the current kernel should you wish to not enter with the LTS one.
BTW, I don`t really remember. Is there an option to include the LTS kernel during installation in our iso?

1 Like

not yet.

it is possible to change the default entry that boots inside /etc/default/grub
GRUB_DEFAULT=2


# GRUB boot loader configuration

GRUB_DEFAULT=2
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="EndeavourOS"

(changes there needs grub.cfg to be rebuilded: sudo grub-mkconfig -o /boot/grub/grub.cfg )

1 Like

First of all million thanks for the direct replies from all of you and the warm welcoming! Secondly million sorries for my late response.

installing LTS kernel solved my problem! thanks again

1 Like

as said before next kernel update will solve this issue for sure :wink:

1 Like