[Solved] Strange graphic problem

Hello, i just installed EndeavourOS, latest updates and it’s amazing.
I’m facing a extrange graphic problem, my screen look like i have a artifac problem but it doesn’t
Check this images, this is how my screen looks. This problem appears in all the active apps. I have to refresh the app or switch to another app and go back to fix the problem.

This is my screenfetch

And this is my neofetch.

Go into ‘Windows Manager Tweaks’, Compositor tab, disable ‘Enable disable compositing’
Just had this issue myself with the new xfce 4.14 and Radeon Vega graphics…

I disable “Enable disable compositing” but the problem continues :frowning:

Welcome @juanprm !

I could try installing, if you don’t have it, xf86-video-amdgpu and then restart.

sudo pacman -S xf86-video-amdgpu

Do you comment ??

It’s already installed, i’m going to reinstall it. Also i’m switching to lts kernel to see if that helps.

He tried the kernel-LTS, maybe that’s better?

sudo pacman -S linux-lts linux-lts-headers

and then

grub-mkconfig -o /boot/grub/grub.cfg



i updated my xfwm4 my self had also a bit not as much as the op… some distortions, disable compositor did the job, cannot allocate what difference can be, beside i use lxqt , but xfwm4 has the same rule yeah got my self an vega 11…

Using the lts-kernel solves the problem, now i can use the compositor normally, now i want to remove the 5.2.8 kernel from the bootup, how i dot that?

1 Like
sudo pacman -R linux linux-headers

and then

grub-mkconfig -o /boot/grub/grub.cfg


When i run that command it prompts this error:

yo dont have to remove the kernel.

edit: if you have to remove the virtualbox modules or needed by linux kernel , but guest is not needed, for virtualbox probably hostmodules-dkms is good choice if you use it

I mean, i want in the bootup only show my windows partition and the EndeavourOS with the lts kernel.

hah yeah you have to place what judd told but you have also remove the virtualbox guest modules

pacman -Qs guest , mostly you can peak intoo like pacman -Qi , on a line needed by i think in english

Solved! thanks a lot for the help/

In the arch forum there is good info, read it if you want.