[Solved] Screen tearing with Intel's GPU

After some time after starting to use EndeavourOS on the new laptop, I noticed some screen tearing when playing videos in firefox, playing video games or in general when the screen needs to be updated often. Looking for a solution I ended up on the wiki page that talks about Intel GPUs, I tried to copy the configuration example but this does not allow X.org to start. Do you have any advice?

Here inxi’s output:
And here the configuration that I tried:
Section "Device" Identifier "Intel Graphics" Driver "intel" Option "AccelMethod" "uxa" Option "TearFree" "true" EndSection
I have tried with and without the Option "AccelMethod" "uxa"

Hello @Airax
Have you removed xf86-video-intel

Edit: Probably need to reboot also before it take effect

I already removed it some time ago

What window manager / desktop environment are you running? often this can be solved by making tweaks to the compositor (although in an ideal world it wouldn’t tear either way)

Maybe try this kernel parameter in the grub command line in /etc/default/grub and generate a new grub file with sudo grub-mkconfig -o /boot/grub/grub.cfg


Im using bspwm as window manager and picom as compositor.
picom’s config:
bspwm’s config:

Do I need to add i915.enable_psr=0 to GRUB_CMDLINE_LINUX_DEFAULT or to GRUB_CMDLINE_LINUX ?

To the deafult grub command line in /etc/default/grub


GRUB_CMDLINE_LINUX_DEFAULT=“quiet i915.enable_psr=0 loglevel=3 nowatchdog”

Save the file with this added and the run

sudo grub-mkconfig -o /boot/grub/grub.cfg

Then reboot and try it.

1 Like

So it seems to resolve the problem with videos in firefox but doesn’t resolve the problem in Wakfu.

What is Wakfu?
Edit: I see it’s a game. So probably something in the game platform.

Edit2: Just see if everything else is okay in Linux and then you’ll have to look into the forums on that game.

Yes it is a games, I’m actualy thinking that is a problem with Java. Anyway the other problem are resolved so I think thats’s time to close the thread

It may be that is the case. I see on their forum regarding small display issue.

“The required version for WAKFU is the Java SE Development Kit 8u161”

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.