[SOLVED] Reboot puzzle

Not sure what category this fits in.


If I use a soft reboot, my computer shuts down but then cannot find Grub2 or an OS and fails to start.

It seems that it cannot find either of my two SSDs and looks instead for a USB device or DVD.

  1. If I shutdown and hit the PC’s start button I get my Grub2 menu as normal.
  2. The PC is dual booted with Windoze. I can reboot Windoze and get back to the Grub2 menu without problem. (No need to touch the power button.)


It’s only soft rebooting (i.e. command line or menu) that causes it to fail to find Grub2 on restart.

What have I done? :confounded:

So you have two SSD? One has Windows One has EndeavourOS? Did you change grub to allow os-prober?

Edit: Windows 10 boot menu option disappeared in the boot menu - #8 by joekamprad

Edt2: Are you getting the grub menu on cold boot and reboot no?

Correct: SSD /sda1 is EOS and SSD /sdb1 is Windoze.

The grub menu is fine but somehow the BIOS seems to get the idea that I don’t have SSDs

And yes, I get the full grub2 menu on a cold start (and Windoze is in that menu as well as EOS). No problem at all with cold starts. And it’s not a problem with Windoze in hibernation mode or some other “quick start” mode. E.g. I can do cold start, load EOS work a bit, do a clean shutdown of EOS. Rins and repeat as many times as I like, but as soon as I do a soft reboot, the BIOS says no!

BTW: I have had this computer so long I had to replace the HDs. I have used EOS ever since the plug was pulled on Antergos. Always dual booted. Never had this problem before.

The ONLY circumstance when the problem occurs is soft rebooting from EOS. Doesn’t happen with Windoze.

When I was setting things up, I used the grub-configuration package. Yes, I also enabled os-prober and did all that stuff.

If you want the long story, it’s as follows:

  1. I used Clonezilla to clone my EOS HD onto my new SSD. Perfect, no problems, could soft reboot to my heart’s content.
  2. Later, I realised that I had to do a clean install of Windoze. Probably a good idea as it was in a mess anyway.
  3. Stupidly, I forgot to unplug my EOS SSD. The Windoze installation goes through several restarts and I realised immediately my egregious mistake. But I didn’t want to pull the cable out in the middle of everything so I waited until the first restart . Too late! Grub had gone, EOS was unbootable.
  4. Following the superb EOS tutorials about UEFI and reading about grub etc I got everything fine and dandy.
  5. Except the above. (Sorry I should have told you all that before but I know people are busy.)

I can live with the problem, it’s a minor irritation but it would be good to know why it only happens with a soft reboot.

Did you check Windows for fast start up feature and turn it off? I’m assuming it’s Win 10?

Edit: Also you have secure boot turned off in UEFI?

1 Like

Yes, the fast start is disabled. And yes, it’s the latest version of Windows 10. I disabled it because of another warning about encrypted partitons being kept open on restarts. Which is stupid!

There is fast boot in UEFI and fast start up feature in Win 10. Just to be sure you know what i mean. Also is secure boot disabled in Bios?

Secure boot is disabled in the BIOS. The BIOS has been updated to the latest version, which is dated 2012! (That’s how primitive my BIOS is.)

It’s non UEFI as well. Legacy BIOS

I was just going to ask if it was UEFI or Bios. :wink:

What does this mean? Did you chroot into the system with the live ISO and re-install grub? Or? Because it’s not UEFI? There is a tutorial for both.

What happens if you reboot with command telinit 6 ?
There is also sudo reboot -f but it’s not recommended to use.

What is in your fstab? Are you using UUID’s?

1 Like

I chrooted from the live ISO. I followed the correct tutorial for Legacy BIOS

A couple of questions:

Did you install Grub’s bootloader (for Legac/Bios) at the MBR of sda?

Could you bring up the one time boot menu and choose sdb to boot into Windows? Does it use Window’s own bootloader then?

1 Like

Admittedly, there is a bit of magic I don’t understand and well spotted @xircon ! I did check my fstab because I don’t quite get how the UUIDs can be the same if I just clone without somehow referencing the UUIDs to the new disks. If you really want, here is my fstab

UUID=8ede48ff-060b-4d68-8029-347ed4eab3bd /              ext4    defaults,noatime 0 1
UUID=fd6a1e63-12ee-4b4b-9224-1acb901e7a3a swap           swap    defaults,noatime 0 2

There are other entries as well to do with remote mounts.

EDIT: I always umount any mounted drive before I reboot or shut down.

Is your sata set to IDE or AHCI? try to play around with those settings in BIOS (AHCI is preferred tho)

@pebcak question:

  1. Yes
  2. No I don’t use Windows boot loader or the BIOS bootloader. I just use grub. And the grub menu is as it always was before I changed my hardware. It gives three options, the third one being sdb1 Windows
1 Like

@devout My sata is set to AHCI in the BIOS.

Remember, everything is fine and normal except if I choose to reboot from the EOS command line or menu. Only then does the BIOS seem to think there are no disks.

You could study the following suggestion:

  1. boot into Windows and make a recovery disk in case you need to restore Window’s bootloader later on

  2. boot into EnOS and install Grub’s bootloader onto MBR of sdb as well. sudo grub-install --target=i386-pc /dev/sdb

1 Like

I don’t have telinit either with sudo or without. yay -Ss telinit reveals nothing.

man telinit
No manual entry for telinit

So I don’t know how to do what you suggest.