[solved] Nvidia dkms boots into black screen

Hello! I am new to endeavouros (just recently installed it) and linux in general (just started using linux with pop os in january 2021)

So the problem is I ran sudo nvidia-installer-dkms on the terminal to install nvidia drivers (im following whats on the welcome screen steps) and then I reboot…

When I try to boot into endeavouros, it gives me a black screen and the underscore character (_) blinking and I cannot seem to do anything on my computer except shutting down

This is my specs
Device: Asus Zenbook Q407IQ
OS: triple boot windows 10, endeavouros, and pop os
CPU: AMD Ryzen 5 4500U
GPU: NVIDIA Geforce MX350 (dedicated), AMD Radeon Graphics (Integrated)
Memory: 8gb RAM

That is a hybrid amd/nvidia machine so just installing nvidia-dkms may not have been the right the thing to do. However, since I have never setup a laptop like that, I will let someone else come along and help you.

In the meantime, you should be able to get your system working again by removing nvidia-dkms. After your machine boots try pressing ctrl+alt+f3. Hopefully that will bring you to a TTY with a login prompt. From there you should be able to login and type sudo pacman -R nvidia-dkms and then reboot


I tried this and it seems to still boot into black screen with that underscore thing

Also the display manager that I’m using is LightDM and the DE is XFCE

Here’s lots of info for your system.

You can see which of the links inside are closest to your system and try any of them. Note that the bumblebee alternative is no more recommended, it is for older systems.

1 Like

yeah I reinstalled endeavour and used optimus manager, thanks

1 Like

So… it is solved?
Could you mark this thread as solved too?