[Solved] NotOnlyTV LV5TDLX DVB-T [RTL2832U] doesn't show video and sound

Hello.
Firstly I would like to thank the founders for really pretty OS - EndeavourOS.

I have a problem with my DVB-T NotOnlyTV LV5TDLX [RTL2832U]. I see this device when I type lsusb and it find tv channels with w_scan2. The problem is that any picture and sound doesn’t appear in Kaffeine or VLC, but Kaffeine finds device and tv channels. I attached Kaffeine screenshot. When I use the same device in MX Linux live-cd, it works correctly and I have picture and sound.

Could you help to solve my problem with missing picture and sound in EndeavourOS? Thank you in advance.

lsusb

Bus 003 Device 002: ID 1f4d:c803 G-Tek Electronics Group NotOnlyTV (Lifeview) LV5TDLX DVB-T [RTL2832U]

Kaffeine

16-04-21 18:40:39.467 [Info    ] kaffeine.dev: Found dvb device : Realtek RTL2832 (DVB-T)

https://wiki.archlinux.org/index.php/DVB-T

Have you tried loading the module with

modprobe rtl2832

Yes, of course. I have tried by all of below from DVB-T ArchWiki.

# modprobe dvb_usb_rtl28xxu
# modprobe rtl2830
# modprobe rtl2832

It helps aribb24 package. Now screen and sound work correctly.
Bug: https://bugs.archlinux.org/task/60024?project=1&string=vlc

pacman -Syu aribb24
2 Likes