[SOLVED] No Updates for the Past Two Days on One Computer Only

My wife and I update our computers daily. We have a total of six (6) computers running EndeavourOS. For the past two days, five (5) of them have had normal updates (using yay, as we always do).

But for the past two (2) days, one of the computers has not shown any updates at all.

As you can see, the message states that everything is up to date.

But it can’t be.

(I also tried updating with pamac-aur-git but that didn’t work either.)

I am currently using the latest linux-lts 5.4.74-1 kernel (5.9.3.arch1-1 doesn’t work properly with this computer - nor with two of the others but that’s another problem, having something to do, I believe, with the UEFI/BIOS brand and version on these three computers) but those two other computers update properly).

What, if anything, can I do to get this computer to update? Is there some way to “force” an update using yay?

Thanks for any help.

Lawrence

Use the welcome app to update your mirrors with reflector-simple.

2 Likes

Thank you dalto.

That did it - and I’ll remember to do that periodically in the future.

Thanks again!

Lawrence

1 Like

Program reflector has the capability to refresh mirrors periodically. It is command line and a bit involved to set up though, but by no means difficult.

More information is available using terminal commands:

  man reflector        # especially: systemd integration
  reflector --help     # options to use, like -p, -c, --sort

Edit: the configuration file for the systemd intergation is in
/etc/xdg/reflector/reflector.conf.

1 Like