[SOLVED] No graphic card acceleration

I have installed the latest version of EndeavourOS and have been really enjoying it.

But I did a few updates tonight and it after a reset it says there is no graphic card acceleration.

I use a MSI GTX 1060 3GB card.

Hope someone can help.

Welcome @Morcar
Could you post the output of inxi -Ga

1 Like

Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: Micro-Star MSI
driver: nvidia v: 460.67 alternate: nouveau,nvidia_drm bus ID: 29:00.0
chip ID: 10de:1c02 class ID: 0300
Display: x11 server: X.org 1.20.10 driver: loaded: modesetting
failed: nvidia resolution: <missing: xdpyinfo>
OpenGL: renderer: llvmpipe (LLVM 11.1.0 256 bits) v: 4.5 Mesa 20.3.4
compat-v: 3.1 direct render: Yes

Okay can you follow this guide and if you need help just ask.

Edit: add nvidia-drm.modeset=1 to the kernel parameter inside grub:

sudo nano /etc/default/grub

Add it in this line:

GRUB_CMDLINE_LINUX_DEFAULT="nvidia-drm.modeset=1 resume=UUID=...

ctrl +o enter
ctrl x

Then generate a new grub

sudo grub-mkconfig -o /boot/grub/grub.cfg

Then force early load KMS

sudo nano /etc/mkinitcpio.conf

add nvidia to the modules


ctrl +o enter
ctrl x


sudo mkinitcpio -P

I just tried it and it worked.

Thank you so much in getting it going again.

1 Like

So with inxi -Ga now it should show the renderer as the video card. You can mark it solved if it’s working also.

1 Like

Welcome to the forum @Morcar :partying_face: :tada: :balloon: