(SOLVED) MESA Update

Just updated mesa & I got this on my monitor. I’m thinking I shouldn’t have updated mesa.

Should I wait for the kernel time to synchronize, or should I load the previous kernel & downgrade mesa?

1 Like

Similar issue here.

1 Like

mesa-19.3.4-1downgrade to previous version (19.3.3-1)

For now…
https://bbs.archlinux.org/viewtopic.php?id=252888

2 Likes

Are you using a nvidia card? I’m up to date on my archlinux with my ryzen3 2200G and no problem with mesa and lightdm.

fred@fredo-arch-mate ~ % yay -Qi lightdm | grep Version
Version                  : 1:1.30.0-2
fred@fredo-arch-mate ~ % yay -Qi mesa | grep Version 
Version                  : 19.3.4-1

Yes I am. A GeForce 640 if memory serves me right.

Bug report on Archlinux: https://bugs.archlinux.org/task/65498

Looks like it is a bug with mesa 19.3.4 and nvidia cards (nouveau and nvidia drivers).

https://bbs.archlinux.org/viewtopic.php?pid=1887625#p1887625

AVX2: https://en.wikipedia.org/wiki/Advanced_Vector_Extensions#Advanced_Vector_Extensions_2

Looks like a lot of CPU (made before 2013) are going to suffer :frowning:

I think quickly … mmm … discriminatory or not ??
I don’t know.
:thinking:

Glad I came across this thread before updating!

1 Like

I have plasma installed with Nvidia GTX 1060 and no issue.

[rick@plasma-pc ~]$ yay -Qi mesa | grep Version 
Version         : 19.3.4-1
[rick@plasma-pc ~]$ 

also disable this useless service:
sudo systemctl disable systemd-time-wait-sync.service

1 Like

Here’s the confirmation that the bug has been filed: https://bugs.archlinux.org/task/65498?project=1&pagenum=2

I’ve reinstalled, and won’t update until problem is resolved. Unless someone can tell me how to update without mesa being updated.

Temporarily add ‘mesa’ to the ‘IgnorePkg =’ section of /etc/pacman.conf and do a normal upgrade.

4 Likes

Many thanks! I truly appreciate that.

sudo pacman -Syu --ignore=mesa
should work for a one time ignore.

3 Likes

No issue with the Nvidia 750 Ti…and AMD1600 CPU. Since I use the NVdia drivers with good setup, no issue…

It’s a problem if you are using Nouveau or GDM. I don’t have any issue on Nvidia drivers.

Mesa 19.3.4-2 is already in testing:

https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/mesa&id=f2a2302697da3268ea0353e87b149f3ee6034346

upgpkg: mesa 19.3.4-2

fix illegal instruction ([FS#65498](https://bugs.archlinux.org/task/65498))

So, within a day or two on stable?

1 Like