[Solved] Libwx_baseu-3.0.so.0

Hi,

I have been using veracrypt for ages but I now get the following error:

roger@roger-pc ~ % sudo veracrypt              
veracrypt: error while loading shared libraries: libwx_baseu-3.0.so.0: cannot open shared object file: No such file or directory

Searching around, I found other posts such as this one:
on tenacity-git

tenacity: error while loading shared libraries: libwx_baseu-3.1.so.5: cannot open shared object file: No such file or directory

So I have tried reinstalling veracrypt but this doesn’t change anything, and I have tried to install the library …

roger@roger-pc ~ % yay -Ss libwx_baseu-3.0 

but it doesn’t seem to be available (it is available from Ubuntu, because that’s the advice over there).

Any ideas? I totally rely on veracrypt!

Something you could try is to download the DEB package from:

into some directory, extract it and move the files manually into the appropriate directories. Though this might work, perhaps not a viable solution in the long run. I’m not sure.

But if you cannot get it from the official arch repos, the AUR or build it yourself, this could be worth a shot.

By the way, I just installed veracrypt on my system and it launches just fine.

Make sure your system is up-to-date and reinstall it:

sudo pacman -Syu
sudo pacman -S veracrypt

Weird. I have libwx_baseu-3.1.so.6

root@roger-pc /lib # ls -l libwx_baseu-3.1.so.6
lrwxrwxrwx 1 root root 24 Apr 24 15:46 libwx_baseu-3.1.so.6 -> libwx_baseu-3.1.so.6.0.0

So does this means a veracrypt dependency has been over-written and veracrypt has not caught up yet? Maybe I have to compile veracrypt from source.

BTW: I did try your suggestion using pacman but I already tried this using yay.

1 Like

Check the versions of the packages you have installed.

On a fully updated system I have:

Name            : veracrypt
Version         : 1.25.9-1

It depends among some other things on wxgtk3>=3.0:

Name            : wxgtk3
Version         : 3.0.5.1-3

This one in turns depends on wxgtk-common which provides

wxgtk-common /usr/lib/libwx_baseu-3.0.so
wxgtk-common /usr/lib/libwx_baseu-3.0.so.0
wxgtk-common /usr/lib/libwx_baseu-3.0.so.0.5.0
wxgtk-common /usr/lib/libwx_baseu_net-3.0.so
wxgtk-common /usr/lib/libwx_baseu_net-3.0.so.0
wxgtk-common /usr/lib/libwx_baseu_net-3.0.so.0.5.0
wxgtk-common /usr/lib/libwx_baseu_xml-3.0.so
wxgtk-common /usr/lib/libwx_baseu_xml-3.0.so.0
Name            : wxgtk-common
Version         : 3.0.5.1-3

Where did you get wxgtk-common from?

AUR?

https://aur.archlinux.org/packages?O=0&SeB=nd&K=wxgtk-common&outdated=&SB=p&SO=d&PP=50&submit=Go

PS. I see you are in a root shell, performing things that don’t need elevated privilege. For minimizing the risk of accidentally damage something on your system, I would just use sudo to get root only when it is necessary.

1 Like

Quite right. I very rarely use root. It seems that I have too recent a version of wxgt3. My version of veracrypt is the same as yours but I have libwx_baseu-3.1.so.6 installed. So I suppose I need to down-grade wxWidgets. Many thanks for your help.

Yes. I would do so.

Also, if you consider that your issue has been resolved, please consider to mark the thread as solved by picking the appropriate post and checking the box for “solution”.

:enos_flag:

1 Like

I will have to think about how I came to have this version. I expect it came as a dependency from something else, or something didn’t work and I spotted a bleeding edge version which cured that. I have been trying to use gtk-glade for ham-fisted GUI developments. Anyway, many thanks!! I program in Julia so sometimes there’s a dependency from some plotting package.

So, I have the correct version of wxgtk3:

roger@roger-pc ~ % sudo pacman -Q wxgtk3
wxgtk3 3.0.5.1-3

Here are the dependencies affected by its removal:

roger@roger-pc ~ % yay -R wxgtk3         
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing wxgtk3 breaks dependency 'wxgtk3' required by erlang
:: removing wxgtk3 breaks dependency 'wxgtk3>=3.0' required by veracrypt
:: removing wxgtk3 breaks dependency 'wxgtk3' required by wxmaxima

So I removed all three and then removed wxgtk3. Did a yay -Sc to clear the caches. Installed veracrypt, happily observing it pulled down the wxgtk3 dependencies it needed.

But nothing has changed! :frowning: Still the same error. I’m reluctant to just delete the offending libraries because I don’t know what will break if I do, or indeed, whether the correct versions will be pulled down when I repeat the above.

Check again the version of your wxgtk-common.

Those “offending” libraries come from this package.

Hey! I think a failing loop is detected :laughing:
I would suggest this approach with similar issues:

  • Locate the actual path of the file (.so) in file system. Example:
$ locate -beq "libwx_baseu-3.0.so.0"
/usr/lib/libwx_baseu-3.0.so.0
/usr/lib/libwx_baseu-3.0.so.0.5.0
  • Check the owner of the file
$ pacman -Qo /usr/lib/libwx_baseu-3.0.so.0
/usr/lib/libwx_baseu-3.0.so.0 is owned by wxgtk-common 3.0.5.1-3
  • Query the base file name (not the path) in upstream DB
pacman -F "libwx_baseu-3.0.so.0"
extra/wxgtk-common 3.0.5.1-3 [installed]
    usr/lib/libwx_baseu-3.0.so.0
chaotic-aur/lib32-wxgtk3 3.0.5.1-3
    usr/lib32/libwx_baseu-3.0.so.0
  • Query similar name in local pacman DB
$ pacman -Qs wxgtk-common
local/wxgtk-common 3.0.5.1-3
    Common libraries and headers for wxgtk2 and wxgtk3
  • Query similar name in upstream pacman DB
$ pacman -Ss wxgtk-common
extra/wxgtk-common 3.0.5.1-3 [installed]
    Common libraries and headers for wxgtk2 and wxgtk3
chaotic-aur/wxcommon-dev-light 3.1.6-1
    wxWidgets common & base. Development branch (GNOME/GStreamer free!)

Now you have all the available info to solve your issue. :wink:

On Topic, you may have manually installed (without pacman) something similar in other than standard package’s path, included in your $PATH, example /usr/local/, /opt/, /usr/lib32/, $HOME/.local/ or other (echo $PATH)

2 Likes

You guys are amazing. Many thanks! I had wxgtk-common-dev installed which pulled the newer libraries that stopped veracrypt from working. It’s all fine and dandy now. :slight_smile:

2 Likes