[Solved] Latest version on extra (darktable) not installing?

I’m guessing there must be something wrong with my mirrors or something. I’m running:

sudo pacman -S darktable

but it keeps showing me options to reinstall darktable-2:4.4.2-3. However, 2.4.6 has been out on arch extra for a while now ( https://archlinux.org/packages/extra/x86_64/darktable/ ). Would appreciate any guidance on figuring out what’s wrong with my system that’s preventing the latest version of the package from installing.

Did you try command

sudo pacman -Syu darktable

?

Yes… though I just solved it. Turns out my mirror list only had dead mirrors. Went to https://archlinux.org/mirrorlist/ and generated a new mirror list for my country and put them in /etc/pacman.d/mirrorlist, ran sudo pacman -Syyu and 522 things updated :slight_smile:

1 Like