SOLVED Latest update changed GRUB

Hello EOS community, hope you are doing fine.

Noticed today an update in which a grub.pacnew was generated.
Usually, when this happens, I run a “Pacdiff & Meld” to use the new configuration file.
To be sure that everything was up to date, I also run a “sudo grub-mkconfig -o /boot/grub/grub.cfg”

During boot, noticed that the grub is now similar to Arch, no more EOS customizations to it.
I suspect that this is not an expected behavior, right?

[2021-02-24T17:05:29-0300] [ALPM] warning: /etc/default/grub installed as /etc/default/grub.pacnew
[2021-02-24T17:05:29-0300] [ALPM] upgraded grub (2:2.04-9 -> 2:2.04-10)
[2021-02-24T17:05:30-0300] [ALPM] running 'grub-fix-initrd-generation.hook'...
[2021-02-24T17:05:30-0300] [ALPM-SCRIPTLET] ===> INFO: grub-tools / grub-fix-initrd-generation:
[2021-02-24T17:05:30-0300] [ALPM-SCRIPTLET] ===> INFO: /etc/grub.d/30_os-prober changed. See file /var/log/grub-fix-initrd-generation.log.
[2021-02-24T17:05:30-0300] [ALPM-SCRIPTLET] ===> INFO: /etc/grub.d/10_linux changed. See file /var/log/grub-fix-initrd-generation.log.
[2021-02-24T17:05:31-0300] [ALPM-SCRIPTLET] Generating grub configuration file ...
[2021-02-24T17:05:32-0300] [ALPM-SCRIPTLET] Found theme: /boot/grub/themes/EndeavourOS/theme.txt

This last one “EndeavourOS SMT Disabled, on linux”, was manually created by me inside /etc/grub.d/40_custom

Seems you are lacking a number of packages if your system still identifies as Arch?
Any of these missing?


Yesterday, it was normal, this happened today, after the update and Pacdiff & Meld, plus the “sudo grub-mkconfig -o /boot/grub/grub.cfg”

[marcelo@linux ~]$ sudo pacman -Ss lsb-release
[sudo] senha para marcelo: 
community/lsb-release 1.4-18 [instalado]
    LSB version query program
[marcelo@linux ~]$ LANG=C sudo pacman -Ss lsb-release
community/lsb-release 1.4-18 [installed]
    LSB version query program
[marcelo@linux ~]$ LANG=C sudo pacman -Ss grub-tools
endeavouros/grub-tools 1.6.2-1 [installed]
    Fixes, additions and enhancements to grub and os-prober.
[marcelo@linux ~]$ LANG=C sudo pacman -Ss grub2-theme-endeavouros
endeavouros/grub2-theme-endeavouros 20210131-1 [installed]
    EndeavourOS grub2 theme
[marcelo@linux ~]$ LANG=C sudo pacman -Ss eos-hooks
endeavouros/eos-hooks 1.4.5-1 [installed]
    EndeavourOS pacman hooks
[marcelo@linux ~]$ LANG=C sudo pacman -Ss endeavouros-theming
endeavouros/endeavouros-theming 6.3-1 [installed]
    Default EndeavourOS background images and icons for all different DE
[marcelo@linux ~]$ 

Forgot to mention that I chose the option “O” in Pacdiff & Meld, to overwrite the file with the new configuration file.

I just did the update. The difference of course is that I always ignore the pacnews unless there is an actual reason not to. I usually only care about updates to the Endeavour Mirrorlist and ignore all other pacnews completely.

Seems the .pacnew in question is just the default arch grub (Just opened it in a text editor). Which makes sense since it is well… the default Arch grub.

1 Like

Exactly, it’s the default arch grub…

I ran a timeshift yesterday, I could restore that file, and run again the “sudo grub-mkconfig -o /boot/grub/grub.cfg” to fix it, but I guess this wasn’t an expected behavior, I thought that it would be nice to report it here.

This is why I asked if you missed some of the packages I mentioned, they are the ones that help Endeavour “Identify” as Endeavour. grub-tools should replace “Arch” with “EndeavourOS” for example automatically.

1 Like

Everything is installed… Just don’t do like me and overwrite files without checking the changes first hehehe