[SOLVED] Installed Timeshift and get dependency error *crontab when launching

I installed KDE Timeshift, and I get an error message when I try to launch it.
“Missing Dependencies”
Commands listed below are not available on this system:
*crontab
Please install required packages and try running TimeShift again.

I have already installed “timeshift” and “timeshift-autosnap”. I also have the same program installed on my laptop which runs on Arcolinux, and there is no problem there.
What other dependencies am I missing?

on my plasma I don’t have Timeshift, as there is already native software

Try installing:

sudo pacman -S vte3 and sudo pacman -S libgee, sudo pacman -S psmisc

Also, just in case you use wayland, this may help:

I just installed “xorg-xhost”, and I still get the same error.
“Missing Dependencies”

1 Like

Do:
yay cronie
In a terminal and select 1

    A library-based package manager with dependency support
core/pacman-mirrorlist 20200207-1 [installed]
    Arch Linux mirror list for use by pacman
extra/expac 10-1
    pacman database extraction utility
extra/namcap 3.2.10-1
    A Pacman package analyzer
extra/pkgfile 21-1
    a pacman .files metadata explorer
community/pacman-contrib 1.3.0-1 [installed]
    Contributed scripts and tools for pacman systems
community/pacmanlogviewer 1.4.1-1
    Inspect pacman log files
community/pacmatic 20150126-2
    A pacman wrapper to avoid bricking your system and such other surprises.
community/pacredir 0.4.2-1
    redirect pacman requests, assisted by avahi service discovery
community/perl-cpanplus-dist-arch 1.32-5
    CPANPLUS backend for building ArchLinux pacman packages
community/reflector 2020.3-1 [installed]
    A Python 3 module and script to retrieve and filter the latest Pacman mirror
    list.
community/snap-pac 2.3.1-1
    Pacman hooks that use snapper to create pre/post btrfs snapshots like
    openSUSE's YaST
endeavouros/yay 9.4.6-2 [installed]
    Yet another yogurt. Pacman wrapper and AUR helper written in go.
[elloquin@elloquin-pc ~]$ sudo pacman -Ss chronie
[elloquin@elloquin-pc ~]$ yay cronie
2 aur/cronie-selinux 1.5.5-1 (+19 0.00%) 
    Daemon that runs specified programs at scheduled times and related tools with SELinux support
1 core/cronie 1.5.5-1 (78.1 KiB 233.4 KiB) (Installed)
    Daemon that runs specified programs at scheduled times and related tools
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==> 

Then
systemctl reboot

1 Like

That worked. Could you tell me what does ‘yay cronie’ exactly do?

I can but it will be a few minutes I am at the gas station :hugs:

1 Like

https://wiki.archlinux.org/index.php/Cron

1 Like

Moving this to the newbie section as it is not a desktop environment issue nor a plasma issue.

2 Likes

Very basically. (I am fairly new to linux).

Please read the wiki @JR29 posted as to what cron is. cronie is a part of cron. As you have probably already seen timeshift is capable of running scheduled back ups. To do so it relies on a package called cronie. “Daemon that runs specified programs at scheduled times and related tools”

Endeavouros is basically a vanilla archlinux install with some nice features added to get you up and running quickly and make it more new user friendly. As such it has a very minimal amount of packages installed. Timeshift is an AUR package as is not in the archlinux official repositories. If you install packages from the AUR you will run into issues like this from time to time.

1 Like

I’m all good now. Thank you guys. I’ve already learned a ton in just a few days! This is truly a great sold community! :smiley:

3 Likes

Glad we got you sorted. If my post is the solution to your issue you should click the three dots at the bottom and put a check mark in the box (click it) to select it as the solution. This will help others when searching for similar issues to search for the solution :wink:

2 Likes

Did it, thanks again.

1 Like