[SOLVED] How do I get the Bluetooth to Work on my ZaReason Ultralap?

I have just installed EndeavourOS onto my ZaReason Ultralap 6440 which I purchased in April of this year. It has an i5 processor and a 1 TB SSD.

I had Antergos installed previously and the Bluetooth ‘just worked.’ I often play Internet Radio Stations on this computer and ‘send’ the sound to an external Bluetooth speaker.

But, regardless of what Bluetooth programs (bluez in various incarnations, blueman, bluedevil, vairious Bluetooth utilities etc.) I have installed, I cannot get the Bluetooth to function within EndeavourOS. When trying the Bluetooth Manager I get a message that the Blueman (or Bluetooth) Daemon will not start. The message states that there MAY NOT BE a Bluetooth module present.

Obviously the computer DOES have a built-in Bluetooth module. After all, it did function perfectly when I had Antergos installed (up until yesterday!). But now, with EndeavourOS, I cannot get access to it.

So now I have removed every program referencing Bluetooth that I had installed except bluez-libs and sbc (they issue a warning that if I remove them, I’ll also remove, among other things, the network manager - and I’m not about to do that!).

I should mention that I have tried installing bluez-ps3 a couple of times and the installation always fails due to some Test failing.

Would someone ‘who knows’ please tell me what I have to do (what programs I need to install) to make the Bluetooth function work on this computer?




Thanks for the information. I went to the site and installed the two programs. But no go.

I tested to see if the module is present. Here, when I run lsmod, is what shows in the Terminal:

[ultralap-6440-i5-2@ultralap-6440-i5-2 ~]$ lsmod
Module Size Used by
ccm 20480 6
fuse 135168 3
joydev 28672 0
mousedev 24576 0
btusb 57344 0
btrtl 20480 1 btusb
btbcm 16384 1 btusb
btintel 28672 1 btusb
bluetooth 675840 5 btrtl,btintel,btbcm,btusb
uvcvideo 114688 0
videobuf2_vmalloc 20480 1 uvcvideo
videobuf2_memops 20480 1 videobuf2_vmalloc
videobuf2_v4l2 28672 1 uvcvideo
videobuf2_common 57344 2 videobuf2_v4l2,uvcvideo
videodev 237568 3 videobuf2_v4l2,uvcvideo,videobuf2_common
ecdh_generic 16384 1 bluetooth
media 61440 4 videodev,videobuf2_v4l2,uvcvideo,videobuf2_common
ecc 32768 1 ecdh_generic
snd_hda_codec_hdmi 69632 1
snd_hda_codec_realtek 126976 1
sof_pci_dev 20480 0
snd_sof_intel_hda_common 73728 1 sof_pci_dev
snd_hda_codec_generic 94208 1 snd_hda_codec_realtek
snd_sof_intel_hda 20480 1 snd_sof_intel_hda_common
intel_rapl 28672 0
snd_sof_intel_byt 28672 1 sof_pci_dev
ledtrig_audio 16384 2 snd_hda_codec_generic,snd_hda_codec_realtek
snd_sof_intel_ipc 20480 1 snd_sof_intel_byt
snd_sof 118784 4 snd_sof_intel_hda_common,snd_sof_intel_byt,snd_sof_intel_ipc,sof_pci_dev
arc4 16384 2
x86_pkg_temp_thermal 20480 0
intel_powerclamp 20480 0
snd_sof_xtensa_dsp 16384 1 sof_pci_dev
coretemp 20480 0
snd_soc_skl 118784 0
kvm_intel 319488 0
snd_soc_hdac_hda 24576 2 snd_sof_intel_hda_common,snd_soc_skl
snd_hda_ext_core 36864 4 snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl,snd_sof_intel_hda
kvm 770048 1 kvm_intel
snd_soc_skl_ipc 73728 1 snd_soc_skl
irqbypass 16384 1 kvm
nls_iso8859_1 16384 1
snd_soc_sst_ipc 20480 1 snd_soc_skl_ipc
nls_cp437 20480 1
snd_soc_sst_dsp 40960 1 snd_soc_skl_ipc
snd_soc_acpi_intel_match 28672 3 snd_sof_intel_hda_common,sof_pci_dev,snd_soc_skl
vfat 24576 1
snd_soc_acpi 16384 3 snd_soc_acpi_intel_match,sof_pci_dev,snd_soc_skl
i915 2265088 4
wl 6467584 0
fat 86016 1 vfat
iwlmvm 466944 0
snd_soc_core 290816 4 snd_sof,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl
crct10dif_pclmul 16384 1
crc32_pclmul 16384 0
snd_compress 28672 1 snd_soc_core
ac97_bus 16384 1 snd_soc_core
snd_pcm_dmaengine 16384 1 snd_soc_core
ghash_clmulni_intel 16384 0
mac80211 999424 1 iwlmvm
snd_hda_intel 49152 3
i2c_algo_bit 16384 1 i915
snd_hda_codec 159744 5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek,snd_soc_hdac_hda
drm_kms_helper 225280 1 i915
mei_hdcp 24576 0
iTCO_wdt 16384 0
intel_wmi_thunderbolt 20480 0
iwlwifi 385024 1 iwlmvm
iTCO_vendor_support 16384 1 iTCO_wdt
snd_hda_core 102400 10 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl,snd_sof_intel_hda
snd_hwdep 20480 1 snd_hda_codec
drm 499712 5 drm_kms_helper,i915
aesni_intel 372736 4
snd_pcm 135168 10 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_sof,snd_sof_intel_hda_common,snd_soc_core,snd_soc_skl,snd_hda_core,snd_pcm_dmaengine
aes_x86_64 20480 1 aesni_intel
crypto_simd 16384 1 aesni_intel
r8169 98304 0
cryptd 24576 2 crypto_simd,ghash_clmulni_intel
glue_helper 16384 1 aesni_intel
intel_cstate 16384 0
snd_timer 40960 1 snd_pcm
input_leds 16384 0
intel_gtt 24576 1 i915
rtsx_pci_ms 24576 0
realtek 20480 1
tpm_crb 20480 0
intel_uncore 139264 0
cfg80211 856064 4 wl,iwlmvm,iwlwifi,mac80211
psmouse 180224 0
libphy 98304 2 r8169,realtek
memstick 20480 1 rtsx_pci_ms
intel_rapl_perf 16384 0
snd 110592 16 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm
agpgart 53248 2 intel_gtt,drm
mei_me 45056 1
pcspkr 16384 0
syscopyarea 16384 1 drm_kms_helper
sysfillrect 16384 1 drm_kms_helper
sysimgblt 16384 1 drm_kms_helper
tpm_tis 16384 0
mei 126976 3 mei_hdcp,mei_me
i2c_i801 36864 0
fb_sys_fops 16384 1 drm_kms_helper
soundcore 16384 1 snd
rfkill 28672 5 bluetooth,cfg80211
intel_pch_thermal 16384 0
tpm_tis_core 24576 1 tpm_tis
ac 16384 0
battery 24576 0
wmi 36864 1 intel_wmi_thunderbolt
tpm 73728 3 tpm_tis,tpm_crb,tpm_tis_core
intel_hid 20480 0
evdev 24576 15
mac_hid 16384 0
rng_core 16384 1 tpm
sparse_keymap 16384 1 intel_hid
pcc_cpufreq 20480 0
pkcs8_key_parser 16384 0
sg 40960 0
crypto_user 16384 0
ip_tables 36864 0
x_tables 49152 1 ip_tables
ext4 770048 1
crc32c_generic 16384 0
crc16 16384 2 bluetooth,ext4
mbcache 16384 1 ext4
jbd2 131072 1 ext4
sd_mod 57344 4
ahci 40960 3
libahci 40960 1 ahci
libata 282624 2 libahci,ahci
serio_raw 20480 0
atkbd 36864 0
rtsx_pci_sdmmc 32768 0
libps2 20480 2 atkbd,psmouse
xhci_pci 20480 0
mmc_core 184320 1 rtsx_pci_sdmmc
scsi_mod 249856 3 sd_mod,libata,sg
crc32c_intel 24576 2
xhci_hcd 278528 1 xhci_pci
rtsx_pci 81920 2 rtsx_pci_sdmmc,rtsx_pci_ms
i8042 32768 0
serio 28672 9 serio_raw,atkbd,psmouse,i8042
[ultralap-6440-i5-2@ultralap-6440-i5-2 ~]$

As you can see, btusb is present and, evidently functioning.

Then, running modprobe btusb:

[ultralap-6440-i5-2@ultralap-6440-i5-2 ~]$ modinfo btusb
filename: /lib/modules/5.2.3-arch1-1-ARCH/kernel/drivers/bluetooth/btusb.ko.xz
license: GPL
version: 0.8
description: Generic Bluetooth USB driver ver 0.8
author: Marcel Holtmann marcel@holtmann.org
srcversion: 0D3BFC5405CC051F7A034F8
alias: usb:v8087p0A5Addcdscdpiciscipin
alias: usb:v0930pddcdscdpicFFisc01ip01in
alias: usb:v413CpddcdscdpicFFisc01ip01in
alias: usb:v13D3pddcdscdpicFFisc01ip01in
alias: usb:v050DpddcdscdpicFFisc01ip01in
alias: usb:v0B05pddcdscdpicFFisc01ip01in
alias: usb:v0A5CpddcdscdpicFFisc01ip01in
alias: usb:v04CApddcdscdpicFFisc01ip01in
alias: usb:v0489pddcdscdpicFFisc01ip01in
alias: usb:v0BB4pddcdscdpicFFisc01ip01in
alias: usb:v105BpddcdscdpicFFisc01ip01in
alias: usb:v19FFp0239ddcdscdpiciscipin
alias: usb:v413Cp8197ddcdscdpiciscipin
alias: usb:v0C10p0000ddcdscdpiciscipin
alias: usb:v0BDBp1002ddcdscdpiciscipin
alias: usb:v044Ep3002ddcdscdpiciscipin
alias: usb:v044Ep3001ddcdscdpiciscipin
alias: usb:v04BFp030Addcdscdpiciscipin
alias: usb:v057Cp3800ddcdscdpiciscipin
alias: usb:v05ACp8281ddcdscdpiciscipin
alias: usb:v05ACp821Addcdscdpiciscipin
alias: usb:v05ACp821Fddcdscdpiciscipin
alias: usb:v05ACp821Bddcdscdpiciscipin
alias: usb:v05ACp8218ddcdscdpiciscipin
alias: usb:v05ACp8215ddcdscdpiciscipin
alias: usb:v05ACp8213ddcdscdpiciscipin
alias: usb:v0A5Cp21E1ddcdscdpiciscipin
alias: usb:v0E8Dp763Fddcdscdpiciscipin
alias: usb:v05ACpddcdscdpicFFisc01ip01in
alias: usb:vpddcdscdpicE0isc01ip01in*
alias: usb:vpddcE0dsc01dp04iciscipin*
alias: usb:vpddcE0dsc01dp01iciscipin*
alias: of:NTCusb4ca,301aC*
alias: of:NTCusb4ca,301a
alias: of:NTCusbcf3,e300C*
alias: of:NTCusbcf3,e300
alias: of:NTCusb1286,204eC*
alias: of:NTCusb1286,204e
depends: btintel,btbcm,bluetooth,btrtl
retpoline: Y
intree: Y
name: btusb
vermagic: 5.2.3-arch1-1-ARCH SMP preempt mod_unload **
sig_id: PKCS#7
signer: Build time autogenerated kernel key
sig_key: 43:F6:04:8D:B7:38:2A:CA:47:55:8E:3F:7B:22:EC:D7:9F:D4:AE:32
sig_hashalgo: sha512
signature: 2F:74:DD:AF:69:BC:E3:AC:4B:CB:10:C4:AC:B3:C8:99:33:1B:26:6F:
** 0D:A4:1B:AC:20:C2:2B:5F:66:52:7A:38:81:73:38:B3:12:D9:2D:A8:

** 55:FD:92:F8:cd:BD:71:B5:7D:36:42:EF:84:56:1A:81:08:ED:7C:50:**
** AC:20:17:88:0F:75:BC:D6:48:B3:E3:BA:D6:E9:E1:55:DF:89:C9:5F:**
** A9:50:21:22:47:BA:C1:CB:C9:F1:CC:77:87:7D:FE:70:13:71:BF:A3:**
** 12:0F:72:4F:83:14:0B:A2:A6:F1:B2:71:A5:18:EB:C1:CB:21:66:89:**
** 76:7E:8A:BE:A0:35:78:EC:52:21:2F:EF:86:98:D3:C6:0C:12:B6:1A:**
** CC:BB:54:12:DA:D8:1F:DF:A1:72:42:3C:D7:FD:D6:06:55:EF:EA:CF:**
** C3:7B:8D:36:01:54:C3:AF:F0:D6:D0:72:90:E1:9A:96:86:E3:7D:66:**
** 21:5E:7D:18:B6:96:26:C5:1E:4B:38:01:CE:0A:8B:76:67:C3:7E:62:**
** B3:A8:E1:E9:30:36:3A:99:45:BB:65:E2:0D:A4:22:6E:4B:FB:A6:22:**
** 79:F9:B0:B6:54:8E:74:70:0F:85:87:E0:F6:ED:C1:CF:A3:87:DC:ED:**
** 6F:7C:95:DA:1E:71:41:19:3E:C9:9A:FB:5F:F8:1A:1F:F2:9E:3D:BF:**
** F2:AA:6F:93:de:05:9F:BC:35:42:79:D5:0B:23:12:85:B8:F2:ED:EA:**
** 2F:16:4E:1C:ab:B5:D0:de:BA:E4:89:52:BF:7F:CF:5F:09:7F:A2:cd:**
** 14:14:EA:12:03:E3:B7:6A:6D:27:E9:8A:61:5D:7A:66:86:E0:B4:9B:**
** 27:33:78:C6:95:36:FB:02:6A:0F:97:C7:68:37:61:AC:40:D6:81:FC:**
** 10:5F:FB:F0:6F:8C:69:D9:AD:F5:30:F7:F5:A5:63:93:B2:4B:FB:41:**
** 84:DB:A6:D8:71:6C:A5:EC:7D:88:BD:5A:D1:A1:89:11:E7:26:40:FB:**
** B0:B8:DD:3D:78:1D:14:9F:30:26:8A:DA:BB:90:DC:B2:65:21:3C:FB:**
** 90:D3:B9:51:8C:D4:05:28:73:92:C5:DA:EE:20:1E:5D:FE:84:78:13:**
** 9B:2F:78:E9:FB:27:9C:B4:3C:43:F3:E3:3C:C3:9C:30:DA:5C:7A:A0:**
** B9:8D:F8:AD:27:D6:C7:E7:4C:64:C7:87:D5:4B:CB:B8:DD:96:C7:99:**
** B0:68:27:F3:44:76:39:83:5F:B6:4C:DB:99:D2:BD:75:cd:3E:30:89:**
** EA:F0:8C:FA:8A:85:91:33:C6:FF:AA:C5:0D:91:5E:0F:82:82:37:F9:**
** 8D:59:E0:F9:49:4C:56:20:D0:2E:76:F6**
parm: disable_scofix:Disable fixup of wrong SCO buffer size (bool)
parm: force_scofix:Force fixup of wrong SCO buffers size (bool)
parm: enable_autosuspend:Enable USB autosuspend by default (bool)
parm: reset:Send HCI reset command on initialization (bool)
[ultralap-6440-i5-2@ultralap-6440-i5-2 ~]$

I assume that the above means that the module is present. Is that right? Evidently, however, something is wrong. The last four lines seem to indicate this.

I reinstalled blueman (to have something I can use to control Bluetooth), rebooted, but then when I tried it (Bluetooth Manager), I still get the message:

Connection to BlueZ failed. Bluez daemon is not running, blueman-manager cannot continue. This probably means that there were no Bluetooth adapters detected or Bluetooth daemon was not started.

I’ll be very honest: I have read that Arch Linux page and, frankly, the thing is, most of it is beyond my grasp. I thought I had tried everything it said to do. I even checked in the < /usr/lib/modules/5.2.3-arch1-1-ARCH/kernel/drivers/bluetooth/ > and I see the file < btusb.ko.xz >.

Can you, or anyone, please help me with some instructions that I CAN understand?

Thank you.


I don’t use bluetooth here, i guess i never did. That’s why i linked the wiki (which is the best source for any linux user IMHO)

I understand that the wiki is overwhelming. But unless someone that knows can come and help you, i’m afraid you won’t have alternatives than re-read the wiki again.

install bluez and bluez-utils
enable and start bluetooth.service
be sure your user belongs to lp group
try installing any of the graphical apps, they may be able to handle some stuff automatically for you

Well, I have gotten partial success.

If, when I boot the computer, I open the Teminal and type: systemctl start bluetooth.service the Bluetooth service does start.

But it will not connect via Audio Sink. That option is not offered (neither is Headphones). It only offers Serial Port. If I connect via Serial Port, I cannot output any sound from my computer to my Bluetooth speaker.

PLUS - I have to enter that command systemctl start bluetooth.service each and every time I reboot. In other words, the option is not retained.

PLEASE - there must be SOMEONE who knows what to do.

Please help me.

Thank you.


sudo systemctl enable bluetooth.service

This should automatically start the service for you. You can check your user groups via groups command if you haven’t already. Please share the output.


in pavucontrol , you can select in pulseaudio when you use pulse audio which profile you need to useWhen bluetooth is enable here and attached to the ears, you must sekect the profile and deselect current one…

1 Like

This had worked. The Bluetooth module is automatically connected upon rebooting. Thank you!

By the way, I had previously enabled (as instructed in the Wiki):

### Auto power-on after boot

By default, your Bluetooth adapter will not power on after a reboot. The former method by using hciconfig hci0 up is deprecated, see the release note. Now you just need to add the line AutoEnable=true in /etc/bluetooth/main.conf at the bottom in the [Policy] section:


[Policy] AutoEnable=true

but this did NOT enable automatic loading upon rebooting. Your instruction did.

Again, thank you.


I’m sorry, but I do not understand what you’re saying. I can now have my Bluetooth automatically start (see my previous post) but I CANNOT pair via Audio Sink or Headphones. My only choice is Serial Port.

The computer DOES pair via that Serial Port - but I cannot obtain any sound output via Bluetooth.

I need the computer’s Bluetooth to pair via Audio Sink - but that option is not offered.

How can I get the option of Audio Sink to appear so that I can properly pair my computer to my Bluetooth speaker?

Thanks to anyone who can help. (It’s dinner time now and I won’t be back until tomorrow. Surely there must be SOMEONE who is using Bluetooth in EndeavourOS. Please help me.)


Glad to hear it worked! There’s a few places in the Arch wiki that could use some sprucing up. Cough EFI install cough cough


I don’t have much experience with bluetooth devices either, but I’m curious about a few things.

  1. Did you use Xfce on Antergos as well?

  2. The wiki states a few times to check to make sure rfkill isn’t blocking your bluetooth by using rfkill list

  3. This might seem stupidly obvious (but it’s happened to me before), but could your headphones be on mute?

Yes I used Xfce on Antergos as well as every other GNU/Linux distro (with one exception) I have used in the past four or five years.

Here is the output of rfkill:

[ultralap-6440-i5-2@ultralap-6440-i5-2 ~]$ rfkill list
0: phy0: Wireless LAN
** Soft blocked: no**
** Hard blocked: no**
1: hci0: Bluetooth
** Soft blocked: no**
** Hard blocked: no**
[ultralap-6440-i5-2@ultralap-6440-i5-2 ~]$

As you can see, Bluetooth is not blocked.

Yet when I try to pair my Bluetooth speaker with my computer, I do not have the option of pairing via Audio Sink. The only option offered is Serial Port which does me no good.

And my speaker is not on mute. I also tried pairing with other devices with the same result.

Is there anyone who DOES have experience with Bluetooth on Arch or, preferably, EndeavourOS who can help me?

Thank you.



I got the Bluetooth to work!

I installed alsa-tools [yay -S alsa-tools] and THAT did it!

I was afraid that I’d have to abandon EndeavourOS in favor of another Arch-based OS but, fortunately, now that is not necessary as EVERY PROGRAM that my wife and I use functions perfectly.

I wish it weren’t so difficult or frustrating to accomplish what, on other distros, works straight out of the box. But I certainly CAN understand why the developers would not want to include items which would make their maintenance work harder. (And apparently few people use Bluetooth on their computers.)

But I also wish that Arch weren’t so difficult. It has been said that computer operating systems are “designed by geniuses for use by idiots.”

Exaggerating (but only slightly), I think that Arch is “designed by idiots for use by geniuses.” (Not really, of course.)

And I “ain’t” no genius!

I do thank VERY MUCH everyone who responded to me here and pointed me into the right direction. Now the computer on which I have installed EndeavourOS is fully functional with regard to the programs that my wife and I use. I look forward to using EndeavourOS for many years to come.

Again, THANK YOU ALL for helping me.



Glad to hear you got it working :smiley:


basicly is hanging on, your doing great !


If you are trying to learn Linux, not just use Linux, tenacity is a good characteristic to have.:smiley:

As Yoda said, “You either do or you don’t, there is no try”.

@lhb1142 On this problem, you showed tenacity.


1 Like

And now it’s time to begin to install EndeavourOS on my other four (4) computers currently running Antergos and also to adjust them to LOOK the same and FUNCTION the same.

After all this frustration, etc. (and lots of ‘language’ about Arch Linux in general and EndeavourOS in particular), I’m going to take my time and make sure I do everything right.

Thanks for all of the help, all of the the suggestions, and for all the compliments. I hope that this thread will help anyone who desires to have Bluetooth function on his/her EndeavourOS computer.



Here is what I do. I get a sheet of paper, and start taking notes of every step I take in the order I do them. Note what works and what doesn’t and what fixed it if it didn’t work.

After I get the OS installed and “adjust them to LOOK the same and FUNCTION the same”, I get my notes, fire up Libreoffice Writer (or your favorite editor) and write up a Cheat Sheet. This is a cheat sheet, not a tutorial so you can be somewhat terse. Print the cheat sheet out, and use it for the next 3. Make notes if you see a chance to improve your method of installation. Then transfer these notes to the LibreOffice document. By the 4th computer you should be buzzing right though it.

Then safely store the LibreOffice document on a USB thumb drive or other source of storage. Then down the road if you buy a new computer, or somethings goes wrong, you won’t be sitting there asking yourself “now what did I do the last time to fix this?”

Here is a sample cheat sheet of a UEFI Arch Linux base install “the Arch way”.
Feel free to use it as an example.
I hope you enjoy your EndeavourOS experience.



this is a very good tip. I also follow something similar that was recommended by @just, a moderator from antergos.

I install zim which is sort of “personal wiki” at first i wrote everything that was new, commands i used to install in all distros i tested, packages i liked, how to configure grub etc etc.
You can create as many entries you want. And you can always go back there and search into your precious notes.


@fernandomaroto thanks for the zim tip. I am definitely going to check this out. Available in the Arch repositories?
Thanks friend.