[SOLVED] HELP messed up my install and can't recover with timeshift

Hello, I have a Endeavour OS installation that suddenly can’t boot anymore, fortunaly I had a few timeshifts snapshots so I thought I could just restore from them, but since I coudn’t boot I booted from a live usb from the Endeavour OS, installed timeshift with the AUR, and now timeshift can’t find the snapshots, any ideas on what to do?

edit:
I managed to solve it, when I tried to boot or chroot I got this error

error while loading shared libraries: libncursesw.so.6: cannot open shared object file: No such file or directory

so I booted in to the live usb, mounted my installation to /mnt and ran

sudo pacman -r /mnt -S ncurses

after this I could chroot, and then I tried to use timeshift but I got another error, I don’t have the exact log but it had something to do with vfat, I’m sorry I can’t put more info on this, but after searching it was a problem with the linux kernel and usually reinstalling it fixes the issue, so I reinstalled it, and I also installed the lts kernel just in case

sudo pacman -S linux linux-lts

after this I was able to use timeshift again, and restored my system and everything is working now :slight_smile:

I’m not an expert ok? Follow on your own risk…

But I would try to use bash as init, editing the grub entry during the boot process
Follow steps 1 and 2 only:

After that, I would try to run the sudo timeshift --restore command…

1 Like

that would be the first thing to fix. Did you do any recent updates, what is your hardware, nvidia? more infos please…

did you chroot into your system?

unfortunaly the same error happens when I use bash as init…

I tried to chroot into my system but I get this error:

error while loading shared libraries: libncursesw.so.6: cannot open shared object file: No such file or directory

which is the same error that shows when I try to boot.

My Hardware is a Lenovo Ideapad Flex 5 with intel cpu and GPU

Could you walk us through the commands you entered to choot?

A journal log may help to see why your system did not boot and what event created the issue. See my link above how to create a pastini link with that info if you want more help from the forum.

Could be that an update on this library created the problem. I do not know what that is. Would be worth looking up the package on arch website.

Edit: found a couple of posts. Could it be that you installed a software via AUR and that this software is looking for a 32 bit version of this package, but you have a 64 bit installed. Here is a post that discuss that

Perhaps remove the last AUR package you installed and try rebooting. There is a dependency problem that broke something I think.

If the backups are on the computer itself you should just need a live iso, chroot and do the restore. Otherwise plug in the USB or HD you used and do the same. It will ask which restore point and that’s pretty much all there is to it.

If it’s not working please provide the terminal input/output that failed.

thanks for the help, I managed to solve it, I updated the post with how I solved it

1 Like