[SOLVED] Fresh KDE Online install, a few questions

The online installer OR KDE, listed all the partitions as Devices, all as hard drives.
The problem is, is idk if this is a KDE issue or not.
I noticed this because I’m trying to enable the swap partition that I could
not during the install.

So, bottom line questions are,
-How do I enable swap Correctly, bc I get incorrect permissions, mounted or unmounted?
-The other question is I guess, if anyone might suspect what the problem is?

I’m sure after alot more searching I’d figure it out, but I’m more interested in knowing if this exposes a glitch or problem of some kind.
Thanks for any input.

The more I think about it as well, I did have to install multiple times as when I manually partition installed, Unless I Formatted, it kept telling me user already exsits, but yet completed install.
When I rebooted, it went to the stock login screen instead of KDE which was odd.
However what I didn’t test was what I formatted… ie the boot, root or home. I did all three and it finally gave me the KDE boot to desktop.
IDK if that helps in anyway or not, just adding it in.

You did a fresh install? Did you wipe out Windows then? Did you do manual partitioning or did you select erase disk with swap or something else? What is the hardware? Is it Uefi? Are you able to show either an an image using gparted or command to show the current partitions.

inxi -Fxxco

sudo fdisk -l

This is a totally new machine, wiped clean.
The only thing I’ve done to hers is copy her firefox profile like I did for me when I switched…I haven’t even done that part yet.

However, this is the first fresh install that has produced these results.
It’s a core i3 machine with 4 GB of ram, running 200% better than the one she has with 8GB of ram.

I understand memory isn’t the issue, but that’s the reason for all this, and that’s to get rid of windows, but I can’t stick an unfamiliar rig for her to use if there’s going to be immediate repercussions to my health…
I have to sleep sometime LMAO

So is it Uefi? Could you post the commands?

Actually, I never had the option for a boot uefi now that you ask.
I set my normals

on this machine, no option for uefi, but there was a grub something checkbox above boot, but no boot uefi.

I’ve had to enable swap before, I think it was on my server rig, but thats before the online installer, and used the manual remove default desktop, then install your choice per the instructions, and I did that on a test machine that worked and it let me enable swap on install.
That’s where my questions are coming from.
I get alot of things are tested on VM’s but you never find issues until other hardware comes into play and that’s what pretty much generated my questions.
That’s why I hope this turns out to be helpfull in some way.

Are you able to post the commands?

Oh for the swap I tried?

sudo fdisk -l


inxi -Fxxc0

sudo fdisk -l
just says my swap is sda3 and marked as swap

inxi -Fxxc0 or inxi -Fxxc0 or <-- zero
= command not found

Please post the output of each command putting three ~~~ before and after so it displays properly.

sudo fdisk -l (This is an lower case L)

inxi -Fxxxc0 (Zero)

Edit: Sorry i didn’t leave a space between the -l. I have corrected it.



[rick@xfce-pc ~]$ sudo fdisk -l
[sudo] password for rick: 
Disk /dev/sda: 465.78 GiB, 500107862016 bytes, 976773168 sectors
Disk model: WDC  WDS500G2B0A
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 878C082A-55B7-4178-8A97-C6A848FF418C

Device         Start       End   Sectors  Size Type
/dev/sda1       2048 958261247 958259200  457G Linux filesystem
/dev/sda2  958261248 976773119  18511872  8.8G Linux swap

[rick@xfce-pc ~]$

Edit: You don’t see the three ~~~ but they are before and after what you copy so it displays this way.

sudo fdisk -l
Disk /dev/sda: 298.9 GiB, 320072933376 bytes, 625142448 sectors
Disk model: WDC WD3200AAJS-2
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: DCD1482A-B05A-40B0-A26D-8977E259C209

Device Start End Sectors Size Type
/dev/sda1 34 2050047 2050014 1001M Linux filesystem
/dev/sda2 2050048 206850047 204800000 97.7G Linux filesystem
/dev/sda3 206850048 210946047 4096000 2G Linux swap
/dev/sda4 210946048 625142414 414196367 197.5G Linux filesystem

$ inxi -Fxxxc0
bash: inxi: command not found


yay -S inxi

$ inxi -Fxxxc0

  Host: DCH Kernel: 5.4.13-arch1-1 x86_64 bits: 64 compiler: gcc v: 9.2.0 
  Desktop: KDE Plasma 5.17.5 tk: Qt 5.14.0 wm: kwin_x11 dm: SDDM Distro: EndeavourOS 
  Type: Desktop System: Dell product: Inspiron 620 v: 00 serial: <root required> 
  Chassis: type: 3 v: 00 serial: <root required> 
  Mobo: Dell model: 0GDG8Y v: A00 serial: <root required> BIOS: Dell v: A04 
  date: 11/21/2011 
  Topology: Dual Core model: Intel Core i3-2120 bits: 64 type: MT MCP 
  arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 26350 
  Speed: 1596 MHz min/max: 1600/3300 MHz Core speeds (MHz): 1: 1597 2: 1597 3: 1596 
  4: 1599 
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0102 
  Display: x11 server: X.Org 1.20.7 driver: intel unloaded: fbdev,modesetting,vesa 
  compositor: kwin_x11 resolution: 1024x768~60Hz 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20 
  Sound Server: ALSA v: k5.4.13-arch1-1 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell 
  driver: r8169 v: kernel port: e000 bus ID: 02:00.0 chip ID: 10ec:8168 
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: d0:67:e5:28:9e:1e 
  Local Storage: total: 298.09 GiB used: 8.16 GiB (2.7%) 
  ID-1: /dev/sda vendor: Western Digital model: WD3200AAJS-22B4A0 size: 298.09 GiB 
  speed: 3.0 Gb/s serial: WD-WMAT12016522 rev: 3A01

 scheme: GPT 
  ID-1: / size: 95.62 GiB used: 7.77 GiB (8.1%) fs: ext4 dev: /dev/sda2 
  ID-2: /boot size: 969.2 MiB used: 60.0 MiB (6.2%) fs: ext4 dev: /dev/sda1 
  ID-3: /home size: 193.40 GiB used: 332.2 MiB (0.2%) fs: ext4 dev: /dev/sda4 
  System Temperatures: cpu: 25.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2666 mobo: 891 
  Processes: 175 Uptime: 3h 53m Memory: 3.76 GiB used: 1.04 GiB (27.7%) 
  Init: systemd v: 244 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
  running in: konsole inxi: 3.0.37

The problem i see is the disks are all linux file system. Supposed to be boot, root, swap and home. It’s just labelling? It just need to use gparted and manage flags and label?

Looks like /dev/sda3 is the partition you set aside for swap:

Now, open a Konsole window and type this to see the current state:

swapon -show

In my case this returns:

$ swapon -show
Filename Type Size Used Priority
/dev/zram0 partition 8162000 0 -2

In your case swapon should return nothing, because no swap is set yet.

Next step is to set swap to /dev/sda3:

sudo swapon /dev/sda3

Now run swapon -show again and it should show that this partition has been added as swap.
If not, we need to see the error message/output of swapon.

Once this has worked you will need to make sure this new setting survives a reboot by adding this line to /etc/fstab:

UUID= device_UUID none swap defaults 0 0

Replace the device_UUID part with the UUID of your swap partition which you can find via:

blkid | grep /dev/sda3

And that should be it…
If you want to read up on this somemore check this one: https://wiki.archlinux.org/index.php/Swap

1 Like

I was reading the wiki yesterday, I guess part of the problem was me failing to mention that swapon --show does nothing

$ swapon --show
[major@DCH ~]$

$ sudo swapon /dev/sda3
swapon: /dev/sda3: read swap header failed

Ok, I think I have it now.
I had to remake the swap because it was formatted as ext4

$ sudo mkswap /dev/sda3
$ sudo swapon /dev/sda3
now this works
$ swapon --show

I guess I was confused about what was going on as I would have thought the setup from the installer would have done this.
Thanks for everyones help

1 Like

That’s what I was saying in my original post. I mentioned that all partitions were Linux file system. I just installed KDE on an MBR system the same before I came to work. What I did is manual partitioning and with gparted I set flags for each partition. So I created /boot, /root,/home & swap. I used boot legacy flag for boot partition, root and home and swap. Then I installed and everything was fine. Swap is working as I checked. I’m glad you figured it out yourself that’s great. Good for you. Just remember you can use flags in gparted to label the partitions when you create them manually. It helps also later for identification.

Edit: I think the installer does create swap if you are using erase with swap. But if you create manual partitions you have to mark them accordingly. So the box needed to be changed to linux swap from ext4.

It’s easy to overlook some thing’s sometimes.

If I recall, the on setting I could change was to be able make the partition a swap partition, but could not find flag setting at the time, maybe bc I formatted it as ext instead of swap?

I’ve got another machine I need to redo as well so I’ll go over this part a little more closely as I always do a manual partition so I’m not erasing stuff I don’t want.

I guess when you mentioned in your answer it wasn’t getting through my head all the way. I craving a BigMac :hamburger: for some reason last night, and it wouldn’t let me think straight lol