[SOLVED} Fonts have been changed in KDE and I can't change them back

So I boot my computer and get the welcome menu and the font has been changed to some digital LCD font.
I open Firefox and Thunderbird and its the same.
I open Konsole and it has an italic font, I managed to fix that one though.

Tor-Browser-en was not affected, but Opera & Chromium are.
Also affected pamac-aur-git

I haven’t done anything I can think of to cause this behavior but does anyone know how to reset all the fonts to default or to what they were the day before?

Which fonts are selected in the system settings -> fonts? And in the GTK-menu?
I got Noto Sans 10pt and in Konsole Hack 9pt. I think thats the default. Maybe change those settings and then change it back?

Screenshot_20200201_202848

Screenshot_20200201_203029

2 Likes

Thankyou!
Now, while admit I was in the Application style yesterday, I did not touch the fonts at all.
And now, Thunderbird and Firefox now have a dark theme.
Now having said that, My wifes computer with fresh install had a dark theme when I set the dark theme, but I’ve set dark theme in kde plenty of times and it never changed Thuderbird or Firefox which is odd.
I like it, but it did it as soon as I rebooted from changing font back.
Maybe it was supposed to do this along time ago, but something was stopping it as this is an install built from antergos and maybe something didn’t let the dark themes take affect in those programs? I’m only guessing.

But thankyou, it’s fixed now.

1 Like

Great it worked. :slightly_smiling_face:
Firefox and Thunderbird use GTK, so you have to change the GTK-design-setting you can see in the second screenshot.
https://wiki.archlinux.org/index.php/Uniform_look_for_Qt_and_GTK_applications

2 Likes