[SOLVED!] Boot Time Slower w/KDE Plasma Install & SDDM

I have removed LightDM and have installed SDDM for KDE Plasma 5 (yeah, I took the plunge). For some reason, instead of only staying on this screen for about 1 to 2 seconds like it used on Xfce, it’s hanging around for about 35 seconds.

So, I’m wondering, did I flub up a file? Is there a config I confounded? Is there an SDDM setting that needs situating?

Inquiring minds want to know. What kinds of files would you need (or terminal info) to help me track this down?

TIA guys!

1 Like

https://www.freedesktop.org/software/systemd/man/systemd-analyze.html

systemd-analyze blame 

Hi @joekamprad. Thanks for the quick reply. This is the report. To my untrained eye, I don’t see anything that would make the system go from the clean function to the login screen in 36 seconds…but, I do stress; it’s my untrained eye!

10.632s man-db.service
          4.653s updatedb.service
           827ms upower.service
           678ms lvm2-monitor.service
           549ms dev-sda1.device
           430ms systemd-logind.service
           336ms udisks2.service
           334ms systemd-tmpfiles-clean.service
           297ms systemd-udevd.service
           258ms systemd-journald.service
           236ms ldconfig.service
            93ms systemd-backlight@backlight:intel_backlight.service
            92ms polkit.service
            90ms systemd-udev-trigger.service
            88ms systemd-journal-flush.service
            61ms NetworkManager.service
            53ms avahi-daemon.service
            47ms user@1001.service
            45ms systemd-tmpfiles-setup.service
            41ms systemd-journal-catalog-update.service
            28ms logrotate.service
            28ms systemd-sysusers.service
            25ms colord.service
            25ms systemd-modules-load.service
            15ms user-runtime-dir@1001.service
            15ms systemd-sysctl.service
            15ms systemd-tmpfiles-setup-dev.service
            13ms dev-mqueue.mount

4.653s updatedb.service is the biggest but this is running periodically only…

this shows that the cuprit is not a systemd-service as times are o.k. :wink:

next step boot log / journal:

journalctl -b -0 | curl -F 'f:1=<-' ix.io

Maybe installing and enabling haveged could help here :thinking:

1 Like

Just what I was about to suggest. :wink:

1 Like

Hi. I have this installed already, but I have NO idea what it’s for, or how to use it.

I ran this code, and pasted the link into my browser. It gave me a lot of stuff. Is this something safe to share here on the forums? I can give the link here if you think it’s okay.

it may includes UUIDS of your harddrives, but i do not think this is a security risk…of you do not want to post them at here you can send me the link in a private message …

Hi @joekamprad. I just PM’d you with the link. Just in case…

From the arch wiki:

The haveged project is an attempt to provide an easy-to-use, unpredictable random number generator based upon an adaptation of the HAVEGE algorithm. Haveged was created to remedy low-entropy conditions in the Linux random device that can occur under some workloads, especially on headless servers.

It’s a daemon/service running in the background so you simply have to start/enable it via systemctl. The delay maybe due to low entropy when starting SDDM.

I did the following: (Looks like it’s already running?)

ps -ef | grep haveged
USER     5294  4752  0 00:43 pts/2    00:00:00 grep haveged

It should look like this:

haveged    504     1  0 07:38 ?        00:00:00 /usr/bin/haveged --Foreground --verbose=1
csteinf+  1712  1704  0 07:46 pts/2    00:00:00 grep --colour=auto haveged

Run

sudo systemctl status haveged

to get the status

and

sudo systemctl start haveged
sudo systemctl enable haveged

to start it right away and enable it on boot. Then try a reboot.

Maybe try a

sudo pacman -S haveged

beforehand.

1 Like

Holy crap! @csteinforth! That worked with amazing results! I don’t even think Xfce came up this quickly from a reboot! Wow!

Look, guys…people talk a lot about this community. They talk about how friendly it is, and that’s very true! It’s also an amazing collection of human beings who have extensive information and can share it in a way that makes the neo-intermediates like me feel good about asking questions.

Thank you so much everyone who was involved!!!

I’m marking this “Solved”!

5 Likes

:vulcan_salute:t3:

Glad this helped! It seems most noticeable to me with Plasma for some reason.

1 Like

Does anyone know the exact reason? Heavy workload or something else?

1 Like