[solved] Bluetooth portion of AX200 not working

So, installed Endeavor (kde plasma) on a thinkpad T470 that has a AX200 (not AX201). I know the adapter works both wifi and bluetooth, it worked with Windows, Void, and Mageia 7.1 without issues. After installing Endeavor, wifi portion working exactly as expected. Bluedevil says I have no adapters. lsusb does show the adapter. rfkill does indeed see it and sees no block, hardware or software. I’ve tried reverting to linux-lts kernel thinking maybe it was a kernel issue, no change. Anyone had this issue before?

[root@slumlord ~]# dmesg | grep -i blue
[    3.358293] thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is unblocked
[    4.333267] Bluetooth: Core ver 2.22
[    4.333283] Bluetooth: HCI device and connection manager initialized
[    4.333286] Bluetooth: HCI socket layer initialized
[    4.333288] Bluetooth: L2CAP socket layer initialized
[    4.333291] Bluetooth: SCO socket layer initialized
[    4.645016] Bluetooth: hci0: Firmware revision 0.0 build 128 week 11 2020
[root@slumlord ~]# rfkill list all
0: tpacpi_bluetooth_sw: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

Link to pastebin of the lsusb -v of the bluetooth device:

Hello @tlmiller76
Have you installed any bluetooth packages?

Yes, bluez, bluez-utils, bluedevil, and pulseaudio-bluetooth are all installed.

root@slumlord ~]# pacman -Ss blue | grep installed
extra/bluedevil 1:5.18.5-1 (plasma) [installed]
extra/bluez 5.54-2 [installed]
extra/bluez-libs 5.54-2 [installed]
extra/bluez-qt 5.70.0-1 (kf5) [installed]
extra/bluez-utils 5.54-2 [installed]
extra/pulseaudio-bluetooth 13.0-3 [installed]

Did you enable and start Bluetooth?

sudo systemctl start bluetooth

sudo systemctl enable bluetooth

You know, upon reading that I realized that no, I did not think to do that. And that was indeed the issue. Thanks!

2 Likes

3 Likes

The Arch is with me! I shall never turn to the Dark side! :rofl: Bash me if you will but i will always return to the Terminal!