[SOLVED] Automatically login did not work after installation

G’day all,

I just did a clean install using the Plasma desktop, and I selected to encrypt the drive and automatically login to my account. After the install was done and it had rebooted, I typed in the password to access the parition and boot into the system. Instead of logging in automatically I was greeted with the login screen set to Elarun theme, and it did not automatically login.

In addition, is it possible to have the default theme of SDDM set to Breeze instead? Perhapes that’s why the auto login didn’t work?

Thanks,

devR

1 Like

First of all welcome at EndeavourOS :enos_flag:
—> do you use latest ISO? (20.9.2020) ?
can you provide install log ?: cat /var/log/Calamares.log | curl -F 'f:1=<-' ix.io

1 Like

Welcome @devR and have a nice stay at endeavouros :grinning:

1 Like

Yes, I downloaded the ISO using the torrent link “endeavouros-2020.09.20-x86_64.iso”.

Logs are here: http://ix.io/2A46

1 Like

2020-10-08 - 16:35:19 [6]: [PYTHON JOB]: "Unsetting autologin."
i see in the log that you accidentally unset autologin on the user settings screen.

1 Like

says:

sudo nano /etc/sddm.conf.d/autologin.conf
and add your username and session here:

[Autologin]
User=john
Session=plasma.desktop

Available session types can be found in /usr/share/xsessions/ for X and in /usr/share/wayland-sessions/ for Wayland.

1 Like

Hmm ok, i’ll do the install again then. I don’t recall unsetting it.

1 Like

i do just replicate kde install with encryption and autologin is working here.
What i do add before would let you setup autologin manualöly so it will not be necessary to reinstall :wink:

1 Like

Oh, of course. I was just doing the reinstall to see if I could replicate the issue. Looks like it was fine the second time around.

My mistake! Sorry about that.

1 Like

Glad you got it all sorted. Welcome to the community :beers: